summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/ddd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/ddd')
-rw-r--r--dev-util/ddd/Manifest1
-rw-r--r--dev-util/ddd/ddd-3.3.12-r3.ebuild91
-rw-r--r--dev-util/ddd/ddd-3.3.12-r4.ebuild91
-rw-r--r--dev-util/ddd/files/ddd-3.3.12-gcc44.patch10
-rw-r--r--dev-util/ddd/files/ddd-3.3.12-gdb-disassembler-bug.patch11
-rw-r--r--dev-util/ddd/files/ddd-3.3.12-man.patch16
-rw-r--r--dev-util/ddd/files/ddd-3.3.12-tinfo.patch11
-rw-r--r--dev-util/ddd/metadata.xml15
8 files changed, 246 insertions, 0 deletions
diff --git a/dev-util/ddd/Manifest b/dev-util/ddd/Manifest
new file mode 100644
index 000000000000..2fc748351d28
--- /dev/null
+++ b/dev-util/ddd/Manifest
@@ -0,0 +1 @@
+DIST ddd-3.3.12.tar.gz 5687115 SHA256 3ad6cd67d7f4b1d6b2d38537261564a0d26aaed077bf25c51efc1474d0e8b65c SHA512 1249e4f5f25335f8f2c3616470f7a8f36262c00b8ac12b79f2b2806228de2831ebeb780fe09490e5e8b5b1ca108fe936ae70856f6a6ec02876fc75c7b4a7dbf3 WHIRLPOOL 5f4117036abc0b9f7cadd5547bbd7bd959427f783a5ea7d32be0682c23d31cf48fb45d4d2a2a9688190a6ff35159ebc48b15b295bcceb1f297eaf7133f252bf2
diff --git a/dev-util/ddd/ddd-3.3.12-r3.ebuild b/dev-util/ddd/ddd-3.3.12-r3.ebuild
new file mode 100644
index 000000000000..7abbaf42d872
--- /dev/null
+++ b/dev-util/ddd/ddd-3.3.12-r3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Graphical front-end for command-line debuggers"
+HOMEPAGE="http://www.gnu.org/software/ddd"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3 FDL-1.1"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="+gnuplot readline"
+
+COMMON_DEPEND="
+ sys-devel/gdb
+ sys-libs/ncurses
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ >=x11-libs/motif-2.3:0
+ ppc? ( dev-libs/elfutils )
+ ppc64? ( dev-libs/elfutils )
+ readline? ( sys-libs/readline )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xfontsel
+ gnuplot? ( sci-visualization/gnuplot )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc44.patch"
+ "${FILESDIR}/${P}-gdb-disassembler-bug.patch"
+ "${FILESDIR}/${PN}-3.3.12-man.patch"
+)
+
+DOCS=(
+ AUTHORS CREDITS INSTALL NEWS PROBLEMS README TIPS TODO
+ doc/ddd{-paper.ps,.pdf,-themes.pdf}
+)
+
+AUTOTOOLS_AUTORECONF=1
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ --with-termlib=ncurses
+ $(use_with readline)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ # Remove app defaults
+ rm -f "${S}"/ddd/Ddd
+
+ # Install ddd distribution
+ autotools-utils_src_install
+
+ # Install application icon
+ doicon "${S}"/icons/ddd.xpm
+}
+
+pkg_postinst() {
+ if ! use gnuplot; then
+ echo
+ elog "To enable data visualization in DDD, install sci-visualization/gnuplot,"
+ elog "or re-emerge DDD with gnuplot USE flag (recommended)."
+ elog "For flat file package.use layout:"
+ elog " echo '${CATEGORY}/${PN} gnuplot' >> /etc/portage/package.use && emerge -va gnuplot"
+ elog "For directory package.use layout:"
+ elog " echo '${CATEGORY}/${PN} gnuplot' > /etc/portage/package.use/ddd && emerge -va gnuplot"
+ fi
+ echo
+ elog "To be able to debug java, bash, perl or python scripts within DDD, install respectively:"
+ elog " virtual/jdk"
+ elog " app-shells/bashdb"
+ elog " dev-lang/perl"
+ elog " dev-python/pydb"
+ echo
+}
diff --git a/dev-util/ddd/ddd-3.3.12-r4.ebuild b/dev-util/ddd/ddd-3.3.12-r4.ebuild
new file mode 100644
index 000000000000..8a9365757232
--- /dev/null
+++ b/dev-util/ddd/ddd-3.3.12-r4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Graphical front-end for command-line debuggers"
+HOMEPAGE="http://www.gnu.org/software/ddd"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3 FDL-1.1"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="+gnuplot readline"
+
+COMMON_DEPEND="
+ sys-devel/gdb
+ sys-libs/ncurses
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ >=x11-libs/motif-2.3:0
+ ppc? ( dev-libs/elfutils )
+ ppc64? ( dev-libs/elfutils )
+ readline? ( sys-libs/readline )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xfontsel
+ gnuplot? ( sci-visualization/gnuplot )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc44.patch"
+ "${FILESDIR}/${P}-gdb-disassembler-bug.patch"
+ "${FILESDIR}/${PN}-3.3.12-man.patch"
+ "${FILESDIR}/${PN}-3.3.12-tinfo.patch"
+)
+
+DOCS=(
+ AUTHORS CREDITS INSTALL NEWS PROBLEMS README TIPS TODO
+ doc/ddd{-paper.ps,.pdf,-themes.pdf}
+)
+
+AUTOTOOLS_AUTORECONF=1
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_with readline)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ # Remove app defaults
+ rm -f "${S}"/ddd/Ddd
+
+ # Install ddd distribution
+ autotools-utils_src_install
+
+ # Install application icon
+ doicon "${S}"/icons/ddd.xpm
+}
+
+pkg_postinst() {
+ if ! use gnuplot; then
+ echo
+ elog "To enable data visualization in DDD, install sci-visualization/gnuplot,"
+ elog "or re-emerge DDD with gnuplot USE flag (recommended)."
+ elog "For flat file package.use layout:"
+ elog " echo '${CATEGORY}/${PN} gnuplot' >> /etc/portage/package.use && emerge -va gnuplot"
+ elog "For directory package.use layout:"
+ elog " echo '${CATEGORY}/${PN} gnuplot' > /etc/portage/package.use/ddd && emerge -va gnuplot"
+ fi
+ echo
+ elog "To be able to debug java, bash, perl or python scripts within DDD, install respectively:"
+ elog " virtual/jdk"
+ elog " app-shells/bashdb"
+ elog " dev-lang/perl"
+ elog " dev-python/pydb"
+ echo
+}
diff --git a/dev-util/ddd/files/ddd-3.3.12-gcc44.patch b/dev-util/ddd/files/ddd-3.3.12-gcc44.patch
new file mode 100644
index 000000000000..2464b2b4a9c4
--- /dev/null
+++ b/dev-util/ddd/files/ddd-3.3.12-gcc44.patch
@@ -0,0 +1,10 @@
+--- ddd-3.3.12-orig/ddd/strclass.C
++++ ddd-3.3.12/ddd/strclass.C
+@@ -39,6 +39,7 @@
+ #include <limits.h>
+ #include <new>
+ #include <stdlib.h>
++#include <stdio.h>
+
+ void string::error(const char* msg) const
+ {
diff --git a/dev-util/ddd/files/ddd-3.3.12-gdb-disassembler-bug.patch b/dev-util/ddd/files/ddd-3.3.12-gdb-disassembler-bug.patch
new file mode 100644
index 000000000000..738cda5946f9
--- /dev/null
+++ b/dev-util/ddd/files/ddd-3.3.12-gdb-disassembler-bug.patch
@@ -0,0 +1,11 @@
+--- a/ddd/GDBAgent.C 2004-09-01 20:07:38.000000000 +0200
++++ b/ddd/GDBAgent.C 2010-06-15 14:16:34.000000000 +0200
+@@ -3078,7 +3078,7 @@
+ {
+ string end_( end );
+ normalize_address(end_);
+- cmd += ' ';
++ cmd += ',';
+ cmd += end_;
+ }
+ return cmd;
diff --git a/dev-util/ddd/files/ddd-3.3.12-man.patch b/dev-util/ddd/files/ddd-3.3.12-man.patch
new file mode 100644
index 000000000000..06f9deb806f0
--- /dev/null
+++ b/dev-util/ddd/files/ddd-3.3.12-man.patch
@@ -0,0 +1,16 @@
+diff -ruN ddd-3.3.12/ddd/Makefile.am ddd-my/ddd/Makefile.am
+--- ddd-3.3.12/ddd/Makefile.am 2009-02-11 18:25:07.000000000 +0100
++++ ddd-my/ddd/Makefile.am 2012-11-06 01:48:46.363493473 +0100
+@@ -1371,10 +1371,8 @@
+ man_MANS = ddd.1
+
+ # `ddd.man' has 8-bit format, `ddd.1' has 7-bit format
+-ddd.1: ddd.man $(srcdir)/unumlaut.sed
+- -$(SED) -f $(srcdir)/unumlaut.sed ddd.man | $(DELETE_CR) > $@~ \
+- && $(MV) $@~ $@
+-
++ddd.1: ddd.man
++ iconv -f ISO8859-15 -t UTF-8 ddd.man > ddd.1
+
+
+ # -----------------------------------------------------------------------------
diff --git a/dev-util/ddd/files/ddd-3.3.12-tinfo.patch b/dev-util/ddd/files/ddd-3.3.12-tinfo.patch
new file mode 100644
index 000000000000..ab7df14ae9d9
--- /dev/null
+++ b/dev-util/ddd/files/ddd-3.3.12-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -360,7 +360,7 @@
+ dnl
+ _termlib="${ddd_termlib}"
+ if test "x${ddd_termlib}" = x; then
+- _termlib="mytinfo ncurses curses termcap terminfo termlib"
++ _termlib="mytinfo ncurses tinfo curses termcap terminfo termlib"
+ fi
+ _termlib_path=
+ if test x"${ddd_termlib_libraries_path}" != x; then
diff --git a/dev-util/ddd/metadata.xml b/dev-util/ddd/metadata.xml
new file mode 100644
index 000000000000..8dbd141af8ea
--- /dev/null
+++ b/dev-util/ddd/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>reavertm@gentoo.org</email>
+ <name>Maciej Mrozowski</name>
+ </maintainer>
+ <longdescription lang="en">
+ GNU DDD is a graphical front-end for command-line debuggers such as
+ GDB, DBX, WDB, Ladebug, JDB, XDB, the Perl debugger, the bash debugger,
+ or the Python debugger. Besides ``usual'' front-end features such as
+ viewing source texts, DDD has become famous through its interactive
+ graphical data display, where data structures are displayed as graphs.
+ </longdescription>
+</pkgmetadata>