summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-04-08 22:47:36 +0100
committerMarek Szuba <marecki@gentoo.org>2020-04-08 22:57:56 +0100
commit1d1fb70df84886f5c36983319eda5c61a3384f3e (patch)
tree73bc6a57a0d3766ea9f1b076805525a531557be3 /dev-util/clinfo/clinfo-2.2.18.04.06-r1.ebuild
parentmedia-libs/mesa: do not force use of specific ICD loader (diff)
downloadgentoo-1d1fb70df84886f5c36983319eda5c61a3384f3e.tar.gz
gentoo-1d1fb70df84886f5c36983319eda5c61a3384f3e.tar.bz2
gentoo-1d1fb70df84886f5c36983319eda5c61a3384f3e.zip
dev-util/clinfo: remove eselect-opencl dependency
This was only needed here for OpenCL header files and virtual/opencl takes care of pulling those in now. Technically, even the stable version 2 did this - but 3 is the first one which *officially* makes the virtual provide the API rather than an implementation. Revbump because clinfo hasn't seen any new releases for quite a while now so we cannot rely on a new release to propagate RDEPEND changes to the users. Approved-by: Craig Andrews <candrews@gentoo.org> Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-util/clinfo/clinfo-2.2.18.04.06-r1.ebuild')
-rw-r--r--dev-util/clinfo/clinfo-2.2.18.04.06-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/clinfo/clinfo-2.2.18.04.06-r1.ebuild b/dev-util/clinfo/clinfo-2.2.18.04.06-r1.ebuild
new file mode 100644
index 000000000000..fc1ca3477ce1
--- /dev/null
+++ b/dev-util/clinfo/clinfo-2.2.18.04.06-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Oblomov/clinfo.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Oblomov/clinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool to display info about the system's OpenCL capabilities"
+HOMEPAGE="https://github.com/Oblomov/clinfo"
+LICENSE="CC0-1.0"
+SLOT="0"
+
+DEPEND=">=virtual/opencl-3"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake MANDIR="${ED}"/usr/share/man PREFIX="${ED}"/usr install
+}