summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2023-08-24 16:02:41 -0700
committerBrian Dolbec <dolsen@gentoo.org>2023-08-24 16:32:58 -0700
commita62a7dcf9dc9ea16ba0b85108c5417eae47b4ed4 (patch)
tree4a4dd262357e50c1e0d60c909549d3e4446ae416 /dev-util/buildbot-pkg
parentapp-antivirus/clamav: drop 1.1.1 (diff)
downloadgentoo-a62a7dcf9dc9ea16ba0b85108c5417eae47b4ed4.tar.gz
gentoo-a62a7dcf9dc9ea16ba0b85108c5417eae47b4ed4.tar.bz2
gentoo-a62a7dcf9dc9ea16ba0b85108c5417eae47b4ed4.zip
dev-util/buildbot-pkg: add 3.9.0
Add Zorry to maintaners Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-pkg')
-rw-r--r--dev-util/buildbot-pkg/Manifest1
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-3.9.0.ebuild30
-rw-r--r--dev-util/buildbot-pkg/metadata.xml4
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/buildbot-pkg/Manifest b/dev-util/buildbot-pkg/Manifest
index 8b4dab297664..320ffad3aaeb 100644
--- a/dev-util/buildbot-pkg/Manifest
+++ b/dev-util/buildbot-pkg/Manifest
@@ -1 +1,2 @@
DIST buildbot-pkg-3.6.1.tar.gz 4807 BLAKE2B d492d0ca36fa8634e877bbc56ffd06ff6a7bb477c98bde2e3586dfc64f4b9d394ec1e5bb1a113aad9d2905277805b9f8737babcad669e2b73abb67d156d3126c SHA512 5833581b4551dc204a52a8356bdb110d57a9de022c33b09b7efdc14f5f4a7c0b0e26f9f9a6a076945aec3a5b7089c040ddaaad8d94c6e0217c2cb6b7742c1ac2
+DIST buildbot-pkg-3.9.0.tar.gz 4987 BLAKE2B b7a05d0401efbecbab718c60e40e87d154e42d0a1b3e298d738f291853fd3a96ae984474e55b52b34eb43959bc2399aaaef90582a7bb2fef7e9b60943076ea13 SHA512 96500b53bdcb955146bd3115a93c7b96019da62f81baf81cd736eb0b236b1cec8e2c24c8048c54bd298c15147b807f6e6c6a90bd71fc0dc95a50fffe3aa9f07b
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-3.9.0.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-3.9.0.ebuild
new file mode 100644
index 000000000000..552d4880c8f3
--- /dev/null
+++ b/dev-util/buildbot-pkg/buildbot-pkg-3.9.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="BuildBot common www build tools for packaging releases"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-pkg/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~amd64-linux ~x86-linux"
+
+# No real integration tests for this pkg.
+# all tests are related to making releases and final checks for distribution
+RESTRICT="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -e "/version/s/=.*$/=\"${PV/_p/.post}\",/" -i setup.py || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-util/buildbot-pkg/metadata.xml b/dev-util/buildbot-pkg/metadata.xml
index 1e3ebf4755df..843974e6055d 100644
--- a/dev-util/buildbot-pkg/metadata.xml
+++ b/dev-util/buildbot-pkg/metadata.xml
@@ -5,6 +5,10 @@
<email>dolsen@gentoo.org</email>
<name>Brian Dolbec</name>
</maintainer>
+ <maintainer type="person">
+ <email>zorry@gentoo.org</email>
+ <name>Magnus Granberg</name>
+ </maintainer>
<longdescription lang="en">
BuildBot is a system to automate the compile/test cycle required
by most software projects to validate code changes.