summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/biew/biew-6.1.0-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/biew/biew-6.1.0-r3.ebuild')
-rw-r--r--dev-util/biew/biew-6.1.0-r3.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-util/biew/biew-6.1.0-r3.ebuild b/dev-util/biew/biew-6.1.0-r3.ebuild
new file mode 100644
index 000000000000..5412959d81b6
--- /dev/null
+++ b/dev-util/biew/biew-6.1.0-r3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils flag-o-matic toolchain-funcs versionator
+
+MY_P=${PN}-$(replace_all_version_separators "")
+
+DESCRIPTION="A portable viewer of binary files, hexadecimal and disassembler modes"
+HOMEPAGE="http://beye.sourceforge.net/"
+SRC_URI="mirror://sourceforge/beye/${PV}/${MY_P}-src.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gpm cpu_flags_x86_mmx cpu_flags_x86_sse"
+REQUIRED_USE="cpu_flags_x86_mmx cpu_flags_x86_sse"
+
+RDEPEND="gpm? ( sys-libs/gpm )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ append-flags -mmmx -msse #362043
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-610-fix_localedep-1.patch"
+ epatch "${FILESDIR}/${PN}-610-portable_configure-1.patch"
+ epatch "${FILESDIR}/${PN}-610-crash.patch"
+ sed -i -e 's^man/man1/biew.1^share/man/man1/biew.1^' makefile || die "Failed to edit makefile."
+}
+
+src_configure() {
+ if use gpm; then
+ append-cppflags -DHAVE_MOUSE
+ else
+ append-cppflags -UHAVE_MOUSE
+ fi
+ ./configure --datadir=/usr/share/${PN} \
+ --prefix=/usr \
+ --cc="$(tc-getCC)" \
+ --ld="$(tc-getCC)" \
+ --ar="$(tc-getAR) -rcu" \
+ --as="$(tc-getAS)" \
+ --ranlib="$(tc-getRANLIB)" || die "configure failed."
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/{biew_en,release,unix}.txt
+}
+
+pkg_postinst() {
+ elog
+ elog "Note: if you are upgrading from <=dev-util/biew-6.1.0 you will need"
+ elog "to change the paths in the setup dialog (F9) from /usr/share/ to"
+ elog "/usr/share/biew/ Alternatively, you can delete ~/.biewrc and it will"
+ elog "automatically determine the correct locations on the next run."
+ elog
+}