summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-02 06:36:14 +0000
committerSam James <sam@gentoo.org>2023-02-02 06:36:14 +0000
commit5f4be6a1dbb026977d46e00cde3d2e026da1b125 (patch)
treed387d61888021ed64e63cddbb5efe92c2567232b /dev-util/bcpp
parentgames-board/gnuchess: fix configure w/ Clang 16, fix C++17 compat (diff)
downloadgentoo-5f4be6a1dbb026977d46e00cde3d2e026da1b125.tar.gz
gentoo-5f4be6a1dbb026977d46e00cde3d2e026da1b125.tar.bz2
gentoo-5f4be6a1dbb026977d46e00cde3d2e026da1b125.zip
dev-util/bcpp: add 20230130
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/bcpp')
-rw-r--r--dev-util/bcpp/Manifest2
-rw-r--r--dev-util/bcpp/bcpp-20230130.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/bcpp/Manifest b/dev-util/bcpp/Manifest
index 1cf0aa9fd5c8..55d8d90db559 100644
--- a/dev-util/bcpp/Manifest
+++ b/dev-util/bcpp/Manifest
@@ -1,2 +1,4 @@
DIST bcpp-20221002.tgz 151426 BLAKE2B 6978b30ca684ec5e9eb781955679d333e7efdb389af2b29a341b466387bf4147bc72c54d80eaa6d57770cd720c2074881594418ccbe7aa81241ebeac938499e3 SHA512 a1d2c57e5acabf90f19d3721c79f76867c2b93af51b717af80089ab9dc5117ac28263ceb6aff6544a1040b6fc5115a229759631309c4f6ea9808c6b6eb7d1c92
DIST bcpp-20221002.tgz.asc 729 BLAKE2B 64a211fb84ac6ca2926cb54b06945a908bb19ef15fb8784f4201b29dbc1ebe1be85e8bb0d05d14ebde126508cb33bb9e2d2411fa54b1290246263829d1f4f7f0 SHA512 867b2c04c957daff028a0eaa14ce2c7fd8718dbe9a9af5bf46b293ce51a0a49f823b18978f10f77b7363ff62691683e2945d0d71280185386f19dc7f1cc883d5
+DIST bcpp-20230130.tgz 155972 BLAKE2B f51ae04ef75125d2040f9ef2ab9fb5513ad83fc6095b85bc091bf109d43b066723743c02f703b90f5d4faeb368da86d611d9ce46237c10e31b861b473de49282 SHA512 1fd22707313c098ac2a338425029d2c6355e9042b9bba3d2a6c8d4315dc59a33ea1bfc0cf30671ab2eb1c05981c4be5313a20d357bbbbb4f14374772253b4c30
+DIST bcpp-20230130.tgz.asc 729 BLAKE2B ffd6266919c8598067b09ac9f855c3b1d93dbd4d6536dbd68a12ccbc5f8cc62e10315e44376fc72d40881e43dfa51676a1af46400aed66bf4c2ac1d4a17b499c SHA512 b52cfa95115726ec7b9575ef8a813fc5d1eb8dc7083b19508d5058b80d41203e70d3cd61a18eea4f35755f77e92ce15c2a1f24db0befb3b62dab3b71065a3955
diff --git a/dev-util/bcpp/bcpp-20230130.ebuild b/dev-util/bcpp/bcpp-20230130.ebuild
new file mode 100644
index 000000000000..f5beeb1bf188
--- /dev/null
+++ b/dev-util/bcpp/bcpp-20230130.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+DESCRIPTION="Indents C/C++ source code"
+HOMEPAGE="https://invisible-island.net/bcpp/"
+SRC_URI="https://invisible-island.net/archives/${PN}/${P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${P}.tgz.asc )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-thomasdickey )"
+
+src_compile() {
+ emake CPPFLAGS='-DBCPP_CONFIG_DIR=\"/etc/bcpp/\"'
+}
+
+src_install() {
+ default
+ dodoc CHANGES MANIFEST README VERSION txtdocs/hirachy.txt \
+ txtdocs/manual.txt
+
+ insinto /etc/bcpp
+ doins bcpp.cfg indent.cfg
+}
+
+pkg_postinst() {
+ elog "Check the documentation for more information on how to"
+ elog "Run bcpp. Please note that in order to get help for"
+ elog "bcpp, please run bcpp -h and not the command by itself."
+ elog ""
+ elog "Configuration files are at ${EPREFIX}/etc/bcpp."
+ elog "To use them, use the -c option followed by the filename."
+}