summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-scheme/hop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-scheme/hop')
-rw-r--r--dev-scheme/hop/Manifest1
-rw-r--r--dev-scheme/hop/files/hop.confd4
-rw-r--r--dev-scheme/hop/files/hop.initd45
-rw-r--r--dev-scheme/hop/hop-2.0.1.ebuild47
-rw-r--r--dev-scheme/hop/metadata.xml13
5 files changed, 110 insertions, 0 deletions
diff --git a/dev-scheme/hop/Manifest b/dev-scheme/hop/Manifest
new file mode 100644
index 000000000000..3b5a82a0a6c0
--- /dev/null
+++ b/dev-scheme/hop/Manifest
@@ -0,0 +1 @@
+DIST hop-2.0.1.tar.gz 2407554 RMD160 b9a1ce2dfa7f12cf32665f5c092985ba8e49ba8f SHA1 46fa45c294a205e461ce3664e6741fe5a5b1dff5 SHA256 4f631be4d79a52b81ea7358d22c49cc188665d8e349c13f16b041693bd5a97b3
diff --git a/dev-scheme/hop/files/hop.confd b/dev-scheme/hop/files/hop.confd
new file mode 100644
index 000000000000..1688f64813d5
--- /dev/null
+++ b/dev-scheme/hop/files/hop.confd
@@ -0,0 +1,4 @@
+# /etc/conf.d/hop: config file for /etc/init.d/hop
+
+# see `hop --help` # for valid cmdline options
+#HOP_OPTS=""
diff --git a/dev-scheme/hop/files/hop.initd b/dev-scheme/hop/files/hop.initd
new file mode 100644
index 000000000000..9d111fe181a1
--- /dev/null
+++ b/dev-scheme/hop/files/hop.initd
@@ -0,0 +1,45 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+HOPEXEC=/usr/bin/hop
+HOPUSER=hop
+HOPHOME=/var/www
+PIDFILE=/var/run/hop.pid
+LOGFILE=/var/log/hop
+
+# For user extensions through /etc/conf.d/hop
+HOP_OPTS="--log-file ${LOGFILE} ${HOP_OPTS}"
+
+depend() {
+ need localmount net
+}
+
+logfile() {
+ if [ ! -f ${LOGFILE} ]
+ then
+ touch ${LOGFILE}
+ fi
+ chown ${HOPUSER} ${LOGFILE} || eerror "Cannot create logfile"
+ return 0
+}
+
+start() {
+ logfile || return 1
+
+ ebegin "Starting Hop Web Broker"
+ start-stop-daemon --start --oknodo \
+ --background --chuid ${HOPUSER} \
+ --make-pidfile --pidfile ${PIDFILE} \
+ --exec ${HOPEXEC} --env HOME=${HOPHOME} \
+ -- ${HOP_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Hop Web Broker"
+ start-stop-daemon --stop \
+ --exec ${HOPEXEC} --pidfile ${PIDFILE}
+ eend $?
+}
diff --git a/dev-scheme/hop/hop-2.0.1.ebuild b/dev-scheme/hop/hop-2.0.1.ebuild
new file mode 100644
index 000000000000..1a32ce140f39
--- /dev/null
+++ b/dev-scheme/hop/hop-2.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils multilib user
+
+DESCRIPTION="Hop is a higher-order language for programming interactive web applications"
+HOMEPAGE="http://hop.inria.fr/"
+SRC_URI="ftp://ftp-sop.inria.fr/indes/fp/Hop/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-scheme/bigloo-3.3a[ssl?,threads?]"
+
+RDEPEND="${DEPEND}"
+
+IUSE="ssl threads debug"
+
+pkg_setup() {
+ enewgroup hop
+ enewuser hop -1 -1 /var/lib/hop hop
+}
+
+src_configure() {
+ # Hop doesn't use autoconf and consequently a lot of options used by econf give errors
+ # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --libdir=/usr/$(get_libdir) \
+ --etcdir=/etc/hop \
+ $(use_enable ssl) \
+ $(use_enable threads) \
+ $(use debug && echo "--debug") \
+ || die "configure failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ newinitd "${FILESDIR}/hop.initd" hop || die
+ newconfd "${FILESDIR}/hop.confd" hop || die
+}
diff --git a/dev-scheme/hop/metadata.xml b/dev-scheme/hop/metadata.xml
new file mode 100644
index 000000000000..a424df30ec6f
--- /dev/null
+++ b/dev-scheme/hop/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>scheme</herd>
+ <longdescription lang="en">
+HOP is a new programming language designed for the Web 2.0. It is a higher-order language for programming interactive web applications such as web agendas, web galleries, music players, etc. HOP can be viewed as a replacement for traditional graphical toolkits. HOP is implemented as a Web broker, i.e., a Web server that may act indifferently as a regular Web server or Web proxy.
+ </longdescription>
+ <use>
+ <flag name="ssl">Enable SSL support for hop</flag>
+ <flag name="threads">Enable thread support for hop, it depends on <pkg>dev-scheme/bigloo</pkg> built with threads use flag.</flag>
+ <flag name="debug">Enables building with debug symbols</flag>
+ </use>
+</pkgmetadata>