summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-12-26 10:35:34 +0100
committerHans de Graaff <graaff@gentoo.org>2022-12-27 07:56:26 +0100
commit5aa8d870a79aa4fcf8045b86b01f555c59d495db (patch)
tree5e371d80c2b11daf51fcf840debdcfa5a7ea8161 /dev-ruby
parentdev-ruby/bunny: add 2.20.1 (diff)
downloadgentoo-5aa8d870a79aa4fcf8045b86b01f555c59d495db.tar.gz
gentoo-5aa8d870a79aa4fcf8045b86b01f555c59d495db.tar.bz2
gentoo-5aa8d870a79aa4fcf8045b86b01f555c59d495db.zip
dev-ruby/climate_control: add 1.2.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/climate_control/Manifest1
-rw-r--r--dev-ruby/climate_control/climate_control-1.2.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/climate_control/Manifest b/dev-ruby/climate_control/Manifest
index 0ee6efc27f73..331ee6405b9a 100644
--- a/dev-ruby/climate_control/Manifest
+++ b/dev-ruby/climate_control/Manifest
@@ -1 +1,2 @@
DIST climate_control-1.0.1.gem 9728 BLAKE2B f2d267e86c58fdbb7a85508f56a091166809d108c2e66702df50962086a89a134e6a47a1e53c36272c563f1d4a0225fc613490616d67fbe04e9647b7fe8cfda6 SHA512 2dfd790b444409275571881d19c3712c6542890499f3d55e5f8ea3775166c01adbb216a0749b0c4e126d631cba690c0edc3f8c49143fc0ff3bcc8b25545bf218
+DIST climate_control-1.2.0.gem 10752 BLAKE2B 5c7c1d0b1ec50f12139e47a0c0f2d5753c6165aa96bb995be12f65cef4a222fc4fa96b66e8c475b3ebe2f353c335a6667e12a9a2a8a869331a1f41f72d686d94 SHA512 282f40d5d9d7b4a6577ea13dd92141c985a0c1bd7d6688cb2bca2529721a0523a1e9ac4ba1c6a27a43b286ac664e502698ef2c0578a9030283a4b18f7cb0a5e8
diff --git a/dev-ruby/climate_control/climate_control-1.2.0.ebuild b/dev-ruby/climate_control/climate_control-1.2.0.ebuild
new file mode 100644
index 000000000000..2e5714737d27
--- /dev/null
+++ b/dev-ruby/climate_control/climate_control-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Easily manage your environment"
+HOMEPAGE="https://github.com/thoughtbot/climate_control"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid dependencies on simplecov and git.
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e 's/git ls-files/find * -print/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}