summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2024-03-14 14:40:01 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-04-20 10:44:15 +0300
commit4032aa96f807f9a0094b2cb46df3ed1c5d8067a4 (patch)
tree06be5e271981ad9faf03827a810db4ace12e67df /dev-ruby
parentapp-emulation/vagrant: Clean old version 2.3.7 (diff)
downloadgentoo-4032aa96f807f9a0094b2cb46df3ed1c5d8067a4.tar.gz
gentoo-4032aa96f807f9a0094b2cb46df3ed1c5d8067a4.tar.bz2
gentoo-4032aa96f807f9a0094b2cb46df3ed1c5d8067a4.zip
dev-ruby/hashicorp-checkpoint: Add support ruby33
Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35428 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hashicorp-checkpoint/hashicorp-checkpoint-0.1.5-r3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/hashicorp-checkpoint/hashicorp-checkpoint-0.1.5-r3.ebuild b/dev-ruby/hashicorp-checkpoint/hashicorp-checkpoint-0.1.5-r3.ebuild
new file mode 100644
index 000000000000..f333efc74aed
--- /dev/null
+++ b/dev-ruby/hashicorp-checkpoint/hashicorp-checkpoint-0.1.5-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Internal HashiCorp service to check version information"
+HOMEPAGE="https://www.hashicorp.com"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+# Tests require network
+RESTRICT="test"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/rspec-its )
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -i '/[Bb]undler/d' Rakefile || die
+
+ # Make tests compatible with new ruby versions
+ sed -i -e '/check/ s/opts/**opts/' spec/checkpoint_spec.rb || die
+}