summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-11-16 08:50:02 +0100
committerHans de Graaff <graaff@gentoo.org>2024-11-16 09:12:11 +0100
commit285955d9ec1de39c7b1fa0ab9615a2e2a8a7bc23 (patch)
tree459144b588cf4046fc4829e4f7dd96158a26d911 /dev-ruby
parentdev-ruby/json: add 2.8.2 (diff)
downloadgentoo-285955d9ec1de39c7b1fa0ab9615a2e2a8a7bc23.tar.gz
gentoo-285955d9ec1de39c7b1fa0ab9615a2e2a8a7bc23.tar.bz2
gentoo-285955d9ec1de39c7b1fa0ab9615a2e2a8a7bc23.zip
dev-ruby/pry: add 0.15.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/pry/Manifest1
-rw-r--r--dev-ruby/pry/pry-0.15.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/pry/Manifest b/dev-ruby/pry/Manifest
index 6684ca7b9907..9c1d6e57bb2c 100644
--- a/dev-ruby/pry/Manifest
+++ b/dev-ruby/pry/Manifest
@@ -1 +1,2 @@
DIST pry-0.14.2.tar.gz 239170 BLAKE2B a6370affcee671b293f33f65613607009d46b361fa241e47a1828c85e484dc82909ab8d307c2d20545253dd19115875788d1ab151b793e90246df4a7fec28cff SHA512 890ab8399899864c109919637e2641cafaf2d895db6ab4912bf856799708e08a68f4c9fbb5c505a75c160af30c4eabccfd52fa92cfa1dd3be7ae776ba0476660
+DIST pry-0.15.0.tar.gz 243906 BLAKE2B e5b438ac7329cca2e27d1d47d28f9ec772c6e2068e3389f47ca3e9519d3a2fb44f1ac4b3e3a524a60fc61d712d871b254585f8ccbcaebd0b96935b628210b8cc SHA512 d7f81546d42dc974a0befe3f5b7c17af0ca810231e8c8b8242b5bdccb521753d77cf15db07630c2949a28824165eac3406a84b672f86d5faf3e9e70c7345111e
diff --git a/dev-ruby/pry/pry-0.15.0.ebuild b/dev-ruby/pry/pry-0.15.0.ebuild
new file mode 100644
index 000000000000..e3b0c5b2e9e3
--- /dev/null
+++ b/dev-ruby/pry/pry-0.15.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+RUBY_FAKEGEM_GEMSPEC=${PN}.gemspec
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pry is a powerful alternative to the standard IRB shell for Ruby"
+HOMEPAGE="https://github.com/pry/pry/wiki"
+SRC_URI="https://github.com/pry/pry/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="ruby19"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/coderay-1.1:0
+ =dev-ruby/method_source-1*"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/open4-1.3
+ >=dev-ruby/rake-0.9
+ >=dev-ruby/mocha-1.0
+ )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on git.
+ # Loosen coderay dependency.
+ sed -e '/git ls-files/d' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -e '/[Bb]undler/d' -i spec/spec_helper.rb || die
+
+ # Skip integration tests because they depend too much on specifics of the environment.
+ rm -f spec/integration/* || die
+ sed -i -e '/loads files through repl and exits/askip "depends on parent directory"' spec/cli_spec.rb || die
+}