summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-03-06 20:05:55 +0100
committerHans de Graaff <graaff@gentoo.org>2023-03-07 07:34:51 +0100
commit10e9f89ca02cae9324d4863ce1f34b4a843aae80 (patch)
tree6f1ccb6df8052046fbd1292c385f7c5cc4544c80 /dev-ruby/whole_history_rating
parentdev-ruby/xmlrpc: enable ruby32 (diff)
downloadgentoo-10e9f89ca02cae9324d4863ce1f34b4a843aae80.tar.gz
gentoo-10e9f89ca02cae9324d4863ce1f34b4a843aae80.tar.bz2
gentoo-10e9f89ca02cae9324d4863ce1f34b4a843aae80.zip
dev-ruby/whole_history_rating: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/whole_history_rating')
-rw-r--r--dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r2.ebuild b/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r2.ebuild
new file mode 100644
index 000000000000..1eafbb48a090
--- /dev/null
+++ b/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_TEST="test_units"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure ruby implementation of Remi Coulom's Whole-History Rating algorithm"
+HOMEPAGE="https://github.com/goshrine/whole_history_rating"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/matrix"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ )
+"