summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-31 04:27:16 +0100
committerSam James <sam@gentoo.org>2023-03-31 18:59:35 +0100
commit7b4bf0a9915126aa19b657e558b795beb9cd10e5 (patch)
treee46dd828111610c6c10236ed7cdebe0a5fedb6da /dev-ruby/strptime
parentdev-ruby/jsobfu: enable ruby32 (diff)
downloadgentoo-7b4bf0a9915126aa19b657e558b795beb9cd10e5.tar.gz
gentoo-7b4bf0a9915126aa19b657e558b795beb9cd10e5.tar.bz2
gentoo-7b4bf0a9915126aa19b657e558b795beb9cd10e5.zip
dev-ruby/strptime: enable ruby32, fix tests
Closes: https://bugs.gentoo.org/775380 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/strptime')
-rw-r--r--dev-ruby/strptime/strptime-0.2.5-r2.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-ruby/strptime/strptime-0.2.5-r2.ebuild b/dev-ruby/strptime/strptime-0.2.5-r2.ebuild
index bec5f0bd8e88..242c6d1840de 100644
--- a/dev-ruby/strptime/strptime-0.2.5-r2.ebuild
+++ b/dev-ruby/strptime/strptime-0.2.5-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -29,3 +29,8 @@ IUSE=""
all_ruby_prepare() {
sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
}
+
+each_ruby_test() {
+ local -x TZ=UTC # bug #775380
+ each_fakegem_test
+}