summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-02-08 08:19:32 +0100
committerHans de Graaff <graaff@gentoo.org>2020-02-08 08:51:57 +0100
commit3062009401c353aec2cf8c074631851ca9633f0b (patch)
tree1cb615dc80dd033273f90f9cc00248374de19e96 /dev-ruby/ruby_parser/ruby_parser-3.14.2.ebuild
parentdev-ruby/sexp_processor: add 4.14.0 (diff)
downloadgentoo-3062009401c353aec2cf8c074631851ca9633f0b.tar.gz
gentoo-3062009401c353aec2cf8c074631851ca9633f0b.tar.bz2
gentoo-3062009401c353aec2cf8c074631851ca9633f0b.zip
dev-ruby/ruby_parser: add 3.14.2
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby_parser/ruby_parser-3.14.2.ebuild')
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-3.14.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/ruby_parser/ruby_parser-3.14.2.ebuild b/dev-ruby/ruby_parser/ruby_parser-3.14.2.ebuild
new file mode 100644
index 000000000000..76b25e685651
--- /dev/null
+++ b/dev-ruby/ruby_parser/ruby_parser-3.14.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby parser written in pure ruby"
+HOMEPAGE="https://github.com/seattlerb/ruby_parser"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/sexp_processor-4.9.0:4"
+
+ruby_add_bdepend "test? ( dev-ruby/racc >=dev-ruby/minitest-4.3 >=dev-ruby/sexp_processor-4.13.0:4 )"
+
+DEPEND+=" test? ( dev-util/unifdef )"
+
+all_ruby_prepare() {
+ # Remove reference to perforce method that is not in a released
+ # version of hoe-seattlerb.
+ #sed -i -e '/perforce/d' Rakefile || die
+ sed -i -e '/license/d' Rakefile || die
+ sed -i -e '/Hoe.plugin :isolate/ s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}