summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-23 07:03:41 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-23 07:04:46 +0200
commitfd5e06efa82a9d25d99328f51f14681fe7d3e2f0 (patch)
treedd7b5f2bcf551ee198335efbdf994aa10308d8f2 /dev-ruby/prime
parentdev-ruby/webmock: drop httpclient test dependency (diff)
downloadgentoo-fd5e06efa82a9d25d99328f51f14681fe7d3e2f0.tar.gz
gentoo-fd5e06efa82a9d25d99328f51f14681fe7d3e2f0.tar.bz2
gentoo-fd5e06efa82a9d25d99328f51f14681fe7d3e2f0.zip
dev-ruby/prime: initial import of 0.1.2
Dependency for forthcoming dev-ruby/prime. Extracted from dev-lang/ruby, keywords set accordingly. Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/prime')
-rw-r--r--dev-ruby/prime/Manifest1
-rw-r--r--dev-ruby/prime/metadata.xml11
-rw-r--r--dev-ruby/prime/prime-0.1.2.ebuild29
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/prime/Manifest b/dev-ruby/prime/Manifest
new file mode 100644
index 000000000000..6c571fc28d5f
--- /dev/null
+++ b/dev-ruby/prime/Manifest
@@ -0,0 +1 @@
+DIST prime-0.1.2.tar.gz 9485 BLAKE2B 88db1d22a33405de0bd216baa0a8fa28abc61fe031ae6042a19f0a5c66cf7733b946a52f94165112b45b23331dc68e3168541ec89329ad8d2c016bbf1e33f425 SHA512 a766426884d6b3cd7a586676799db146974ec9a4a7c30ca53b5f279ad55ee9960c9b5bb26988cb66253b4fe974f9b5087f48ef5b216772464d03b8ed78a817d6
diff --git a/dev-ruby/prime/metadata.xml b/dev-ruby/prime/metadata.xml
new file mode 100644
index 000000000000..82f9f0cd0cba
--- /dev/null
+++ b/dev-ruby/prime/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/prime</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/prime/prime-0.1.2.ebuild b/dev-ruby/prime/prime-0.1.2.ebuild
new file mode 100644
index 000000000000..676926a80163
--- /dev/null
+++ b/dev-ruby/prime/prime-0.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="prime.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Prime numbers and factorization library"
+HOMEPAGE="https://github.com/ruby/prime"
+SRC_URI="https://github.com/ruby/prime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's:_relative ": "./:' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}