summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-09-04 06:27:25 +0200
committerHans de Graaff <graaff@gentoo.org>2018-09-04 06:27:25 +0200
commitb8f7e7dea064235d982650260e5c413dea0f630d (patch)
tree5f9689e049b732079416b9ab9ec0c3e3c3c235e5 /dev-ruby/ox/ox-2.10.0.ebuild
parentdev-python/kombu: 4.2.1 bump (diff)
downloadgentoo-b8f7e7dea064235d982650260e5c413dea0f630d.tar.gz
gentoo-b8f7e7dea064235d982650260e5c413dea0f630d.tar.bz2
gentoo-b8f7e7dea064235d982650260e5c413dea0f630d.zip
dev-ruby/ox: add 2.10.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/ox/ox-2.10.0.ebuild')
-rw-r--r--dev-ruby/ox/ox-2.10.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/ox/ox-2.10.0.ebuild b/dev-ruby/ox/ox-2.10.0.ebuild
new file mode 100644
index 000000000000..f03cb3bed818
--- /dev/null
+++ b/dev-ruby/ox/ox-2.10.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fast XML parser and Object marshaller"
+HOMEPAGE="http://www.ohler.com/ox/ https://github.com/ohler55/ox"
+SRC_URI="https://github.com/ohler55/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ox extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/ox
+ cp ext/ox/ox$(get_modname) lib/ox/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/tests.rb || die
+}