summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/net-http-digest_auth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/net-http-digest_auth')
-rw-r--r--dev-ruby/net-http-digest_auth/Manifest1
-rw-r--r--dev-ruby/net-http-digest_auth/metadata.xml8
-rw-r--r--dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4-r1.ebuild24
-rw-r--r--dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4-r2.ebuild24
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-ruby/net-http-digest_auth/Manifest b/dev-ruby/net-http-digest_auth/Manifest
new file mode 100644
index 000000000000..5bc6894ca2a1
--- /dev/null
+++ b/dev-ruby/net-http-digest_auth/Manifest
@@ -0,0 +1 @@
+DIST net-http-digest_auth-1.4.gem 13312 SHA256 11f7a8c13e801455dedd8864339d5fcd6536949b99ec9b3eae193c32f20b0091 SHA512 a743b278bba44541835f28ed86f94a907f7b48e8f314f0cbe6e14888a1d723c0d60cd4bbde5ac02cd263d91a5803021d9fa073d55077ac2b4c2767ebb65624cd WHIRLPOOL 4561e9a11a0601fefa74caaebbd7bef0733f26c7c2e96b4f59bf3b9c2c95d1ecd14d86e9fc4e2f80f086e4b5ce3a17ccf8446c715b8f641ca07874b5f44ad494
diff --git a/dev-ruby/net-http-digest_auth/metadata.xml b/dev-ruby/net-http-digest_auth/metadata.xml
new file mode 100644
index 000000000000..524e0f5e1b1a
--- /dev/null
+++ b/dev-ruby/net-http-digest_auth/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">drbrain/net-http-digest_auth</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4-r1.ebuild b/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4-r1.ebuild
new file mode 100644
index 000000000000..55c028b94ced
--- /dev/null
+++ b/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An implementation of RFC 2617 - Digest Access Authentication"
+HOMEPAGE="http://github.com/drbrain/net-http-digest_auth"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/hoe dev-ruby/minitest )"
diff --git a/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4-r2.ebuild b/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4-r2.ebuild
new file mode 100644
index 000000000000..17442282a493
--- /dev/null
+++ b/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An implementation of RFC 2617 - Digest Access Authentication"
+HOMEPAGE="http://github.com/drbrain/net-http-digest_auth"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/hoe dev-ruby/minitest )"