summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-12-15 14:18:45 +0100
committerHans de Graaff <graaff@gentoo.org>2023-12-15 15:17:42 +0100
commitf41ace65ff6f337002e850d5769a6a7b592d650d (patch)
tree4e2c4443b78417a068ebf38aa7daa56408cea106 /dev-ruby/html2haml
parentsci-mathematics/nauty: add 2.8.8 (diff)
downloadgentoo-f41ace65ff6f337002e850d5769a6a7b592d650d.tar.gz
gentoo-f41ace65ff6f337002e850d5769a6a7b592d650d.tar.bz2
gentoo-f41ace65ff6f337002e850d5769a6a7b592d650d.zip
dev-ruby/html2haml: enable ruby32, fix tests
Closes: https://bugs.gentoo.org/912258 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/html2haml')
-rw-r--r--dev-ruby/html2haml/html2haml-2.3.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-ruby/html2haml/html2haml-2.3.0.ebuild b/dev-ruby/html2haml/html2haml-2.3.0.ebuild
index 0817065ce65c..a80769ef8505 100644
--- a/dev-ruby/html2haml/html2haml-2.3.0.ebuild
+++ b/dev-ruby/html2haml/html2haml-2.3.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="README.md Changelog.markdown"
RUBY_FAKEGEM_RECIPE_DOC="yard"
@@ -26,7 +26,11 @@ ruby_add_rdepend ">=dev-ruby/nokogiri-1.6.0
ruby_add_bdepend "test? ( dev-ruby/minitest )"
all_ruby_prepare() {
- sed -i -e "/bundler/d" test/test_helper.rb || die
+ sed -e "/bundler/d" \
+ -e 's/MiniTest::Unit::TestCase/Minitest::Test/' \
+ -i test/test_helper.rb || die
+ sed -e 's/MiniTest::Unit::TestCase/Minitest::Test/' \
+ -i test/*_test.rb || die
}
each_ruby_test() {