summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-08-14 05:42:11 +0200
committerHans de Graaff <graaff@gentoo.org>2018-08-14 05:42:11 +0200
commit61c909371938b238e1d58bf9f7acc4c8fa0346ac (patch)
tree730dc240881c96a6b4150062c4729b759093646d /dev-ruby/hashie/hashie-3.6.0.ebuild
parentapp-emulation/xen-tools: drop old (diff)
downloadgentoo-61c909371938b238e1d58bf9f7acc4c8fa0346ac.tar.gz
gentoo-61c909371938b238e1d58bf9f7acc4c8fa0346ac.tar.bz2
gentoo-61c909371938b238e1d58bf9f7acc4c8fa0346ac.zip
dev-ruby/hashie: add 3.6.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/hashie/hashie-3.6.0.ebuild')
-rw-r--r--dev-ruby/hashie/hashie-3.6.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/hashie/hashie-3.6.0.ebuild b/dev-ruby/hashie/hashie-3.6.0.ebuild
new file mode 100644
index 000000000000..c5333c7504ba
--- /dev/null
+++ b/dev-ruby/hashie/hashie-3.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hashie is a small collection of tools that make hashes more powerful"
+HOMEPAGE="https://www.mobomo.com/2009/11/hashie-the-hash-toolkit/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activesupport )"
+
+all_ruby_prepare() {
+ # Remove bundler and fix one spec that depends on its requires
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -e '/pry/ s:^:#:' \
+ -e '1irequire "pathname"; require "tempfile"' -i spec/spec_helper.rb || die
+
+ # Avoid dependency on rspec-pending_for and its dependencies
+ sed -i -e '/pending_for/ s:^:#:' \
+ spec/spec_helper.rb \
+ spec/hashie/mash_spec.rb \
+ spec/hashie/extensions/strict_key_access_spec.rb || die
+
+ # Avoid integration specs to avoid complicated dependencies
+ rm spec/integration/{elasticsearch,omniauth*,rails}/integration_spec.rb || die
+}