summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-23 12:02:31 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-23 12:28:08 +0100
commit8be816d0d9c30775206b7680f4d09cf21ee0843b (patch)
tree90e7e047adfef47ced01766db8dbf18aa2ddd43a /dev-ruby/axiom-types
parentdev-ruby/equalizer: cleanup (diff)
downloadgentoo-8be816d0d9c30775206b7680f4d09cf21ee0843b.tar.gz
gentoo-8be816d0d9c30775206b7680f4d09cf21ee0843b.tar.bz2
gentoo-8be816d0d9c30775206b7680f4d09cf21ee0843b.zip
dev-ruby/axiom-types: add ruby30
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/axiom-types')
-rw-r--r--dev-ruby/axiom-types/axiom-types-0.1.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/axiom-types/axiom-types-0.1.1-r1.ebuild b/dev-ruby/axiom-types/axiom-types-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..d2a557a913ef
--- /dev/null
+++ b/dev-ruby/axiom-types/axiom-types-0.1.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Define types with optional constraints for use within axiom and other libraries"
+HOMEPAGE="https://rubygems.org/gems/axiom-types https://github.com/dkubb/axiom-types"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/descendants_tracker-0.0.4
+ <dev-ruby/descendants_tracker-0.1
+ >=dev-ruby/ice_nine-0.11.0
+ <dev-ruby/ice_nine-0.12
+ >=dev-ruby/thread_safe-0.3.1
+ <dev-ruby/thread_safe-1"
+
+RESTRICT="test"