summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-05 06:19:00 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-05 06:19:00 +0200
commita67fd621ce95ab8c9e9ca8e64cd44b5e63240c58 (patch)
treeeb88e651734237771c0c9d1689f874c203f73965 /dev-ruby/autoprefixer-rails/autoprefixer-rails-7.1.1.3.ebuild
parentdev-ruby/i18n: add ruby24 (diff)
downloadgentoo-a67fd621ce95ab8c9e9ca8e64cd44b5e63240c58.tar.gz
gentoo-a67fd621ce95ab8c9e9ca8e64cd44b5e63240c58.tar.bz2
gentoo-a67fd621ce95ab8c9e9ca8e64cd44b5e63240c58.zip
dev-ruby/autoprefixer-rails: add 7.1.1.3
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/autoprefixer-rails/autoprefixer-rails-7.1.1.3.ebuild')
-rw-r--r--dev-ruby/autoprefixer-rails/autoprefixer-rails-7.1.1.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/autoprefixer-rails/autoprefixer-rails-7.1.1.3.ebuild b/dev-ruby/autoprefixer-rails/autoprefixer-rails-7.1.1.3.ebuild
new file mode 100644
index 000000000000..3f028c0f5205
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/autoprefixer-rails-7.1.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
+HOMEPAGE="https://github.com/ai/autoprefixer-rails"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="7"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/execjs:*"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rails
+ dev-ruby/rake
+ dev-ruby/rspec-rails
+)"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
+ sed -i -e "/Bundler/,+3d" spec/app/config/application.rb || die
+ rm spec/rails_spec.rb spec/compass_spec.rb || die
+}