summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/actionpack-action_caching
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/actionpack-action_caching')
-rw-r--r--dev-ruby/actionpack-action_caching/Manifest1
-rw-r--r--dev-ruby/actionpack-action_caching/actionpack-action_caching-1.1.1.ebuild33
-rw-r--r--dev-ruby/actionpack-action_caching/metadata.xml8
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/actionpack-action_caching/Manifest b/dev-ruby/actionpack-action_caching/Manifest
new file mode 100644
index 000000000000..b2fa5d4c1ad6
--- /dev/null
+++ b/dev-ruby/actionpack-action_caching/Manifest
@@ -0,0 +1 @@
+DIST actionpack-action_caching-1.1.1.gem 13312 SHA256 e7715ff3534d124e58fd40ebf6c05708d830fe2c71c2f2643ca060025b00b224 SHA512 6ff988a5f715a8956826bb8941c15eabf9db1b08d223467cfb595c1596c955af86ddebea30a117aeff770092758d1940632acc13583aba9f3fd5793719e70efe WHIRLPOOL b2cca76a39b9fd2d6564f5f0ba96bb7286d13c86e6ddf517dd2c872c1c1573ccf52dadfe0a79433402ca0947c1cd1b68399010fe248f0974eb18935a1d9c45fe
diff --git a/dev-ruby/actionpack-action_caching/actionpack-action_caching-1.1.1.ebuild b/dev-ruby/actionpack-action_caching/actionpack-action_caching-1.1.1.ebuild
new file mode 100644
index 000000000000..2f7322058daf
--- /dev/null
+++ b/dev-ruby/actionpack-action_caching/actionpack-action_caching-1.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Action caching for Action Pack (removed from core in Rails 4.0)"
+HOMEPAGE="https://github.com/rails/actionpack-action_caching"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/actionpack-4.0.0"
+
+ruby_add_bdepend "test? ( >=dev-ruby/activerecord-4.0.0
+ dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" Rakefile test/abstract_unit.rb || die
+ sed -i -e "/git/d" ${PN}.gemspec || die
+ sed -i -e "2irequire 'mocha/setup'" test/caching_test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/caching_test.rb || die
+}
diff --git a/dev-ruby/actionpack-action_caching/metadata.xml b/dev-ruby/actionpack-action_caching/metadata.xml
new file mode 100644
index 000000000000..9380edb67b4d
--- /dev/null
+++ b/dev-ruby/actionpack-action_caching/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rails/actionpack-action_caching</remote-id>
+ </upstream>
+</pkgmetadata>