summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-31 07:57:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-31 11:10:14 +0200
commit5831c6cee813bf1f0f55c7a92b92a717a782ded4 (patch)
tree322f43b23b1b59ffe473849a48c07ec1965ca339 /dev-ros
parentdev-ros/tf2_ros: Bump to 0.7.3. (diff)
downloadgentoo-5831c6cee813bf1f0f55c7a92b92a717a782ded4.tar.gz
gentoo-5831c6cee813bf1f0f55c7a92b92a717a782ded4.tar.bz2
gentoo-5831c6cee813bf1f0f55c7a92b92a717a782ded4.zip
dev-ros/tf2_sensor_msgs: Bump to 0.7.3.
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/tf2_sensor_msgs/Manifest1
-rw-r--r--dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.7.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/tf2_sensor_msgs/Manifest b/dev-ros/tf2_sensor_msgs/Manifest
index e386e7e8eadf..4e3cdf274309 100644
--- a/dev-ros/tf2_sensor_msgs/Manifest
+++ b/dev-ros/tf2_sensor_msgs/Manifest
@@ -1 +1,2 @@
DIST geometry2-0.7.2.tar.gz 174319 BLAKE2B 0f319055cf0a4c8a425c31abc981ee1aee3c77b9dae8e0ddae6a0c4bdf09c31373b8005cb05177374ae5a2139c0f49a4cfdd5b966f8e991827ca2c6e471dcdd2 SHA512 8c2ad4e67d4d7509c3d9a7ef781d454eeb570fbc29d201ece7d2613258b7bed2ba00398655901e2b5856b59acad94422dbb6ae1f0bd545b3a41353204c31d00b
+DIST geometry2-0.7.3.tar.gz 175974 BLAKE2B a0edbeea6db30f07d5cf6ddd4d0a8a1ce0221c8b0ad01929aa6a73a7a49e2e5bd08dfd01cef6cd964ea93b6e8f5aa1dd6ec395e8e4bbafa1117eb3436cae9c10 SHA512 20d207218000905a17411ee9c662778b3022481e84b903ca616cdfc439b2af55c7182988dc843103edc471d564e988fa311be916d0810ec86228585500ed532e
diff --git a/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.7.3.ebuild b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.7.3.ebuild
new file mode 100644
index 000000000000..b6d6fb7ff23f
--- /dev/null
+++ b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.7.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Transform sensor_msgs with tf. Most notably, PointCloud2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_ros[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/python_orocos_kdl[\${PYTHON_USEDEP}]")
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/gtest
+ )
+ dev-ros/cmake_modules
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}