summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-12 16:28:32 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-12 16:31:18 -0400
commitf9317406851545c19a05d65e6d5879c7a883f3c7 (patch)
treec73088a3caca7c4505442bb899b32b85eb65a2fb /dev-qt
parentdev-qt/qtwayland: match accessibility IUSE with qtbase:6 (diff)
downloadgentoo-f9317406851545c19a05d65e6d5879c7a883f3c7.tar.gz
gentoo-f9317406851545c19a05d65e6d5879c7a883f3c7.tar.bz2
gentoo-f9317406851545c19a05d65e6d5879c7a883f3c7.zip
dev-qt/qtdeclarative: match accessibility IUSE with qtbase:6
Makes use of QT_CONFIG(accessibility) which can result in undefined symbols if was enabled on qtbase then flipped off. Like opengl/vulkan, this flag is typically enabled either globally or not at all and should hopefully not cause conflicts for most users. Technically needed in non-live but given the low impact will wait rather than let this trigger rebuilds (esp. given one of the similarly affected package is qtwebengine). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-6.6.9999.ebuild4
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-6.7.9999.ebuild4
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-6.9999.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/dev-qt/qtdeclarative/qtdeclarative-6.6.9999.ebuild b/dev-qt/qtdeclarative/qtdeclarative-6.6.9999.ebuild
index 1eadca9fb01c..7c725f7cc737 100644
--- a/dev-qt/qtdeclarative/qtdeclarative-6.6.9999.ebuild
+++ b/dev-qt/qtdeclarative/qtdeclarative-6.6.9999.ebuild
@@ -11,13 +11,13 @@ if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
-IUSE="opengl +sql vulkan +widgets"
+IUSE="accessibility opengl +sql vulkan +widgets"
# behaves very badly when qtdeclarative is not already installed, also
# other more minor issues (installs junk, sandbox/offscreen issues)
RESTRICT="test"
-RDEPEND="~dev-qt/qtbase-${PV}:6[gui,network,opengl=,sql?,vulkan=,widgets=]"
+RDEPEND="~dev-qt/qtbase-${PV}:6[accessibility=,gui,network,opengl=,sql?,vulkan=,widgets=]"
DEPEND="
${RDEPEND}
vulkan? ( dev-util/vulkan-headers )
diff --git a/dev-qt/qtdeclarative/qtdeclarative-6.7.9999.ebuild b/dev-qt/qtdeclarative/qtdeclarative-6.7.9999.ebuild
index a4e5c61fd98d..235c4f16520f 100644
--- a/dev-qt/qtdeclarative/qtdeclarative-6.7.9999.ebuild
+++ b/dev-qt/qtdeclarative/qtdeclarative-6.7.9999.ebuild
@@ -12,13 +12,13 @@ if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
-IUSE="+network opengl +sql +ssl vulkan +widgets"
+IUSE="accessibility +network opengl +sql +ssl vulkan +widgets"
# behaves very badly when qtdeclarative is not already installed, also
# other more minor issues (installs junk, sandbox/offscreen issues)
RESTRICT="test"
-RDEPEND="~dev-qt/qtbase-${PV}:6[gui,network=,opengl=,sql?,ssl?,vulkan=,widgets=]"
+RDEPEND="~dev-qt/qtbase-${PV}:6[accessibility=,gui,network=,opengl=,sql?,ssl?,vulkan=,widgets=]"
DEPEND="
${RDEPEND}
vulkan? ( dev-util/vulkan-headers )
diff --git a/dev-qt/qtdeclarative/qtdeclarative-6.9999.ebuild b/dev-qt/qtdeclarative/qtdeclarative-6.9999.ebuild
index a4e5c61fd98d..235c4f16520f 100644
--- a/dev-qt/qtdeclarative/qtdeclarative-6.9999.ebuild
+++ b/dev-qt/qtdeclarative/qtdeclarative-6.9999.ebuild
@@ -12,13 +12,13 @@ if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
-IUSE="+network opengl +sql +ssl vulkan +widgets"
+IUSE="accessibility +network opengl +sql +ssl vulkan +widgets"
# behaves very badly when qtdeclarative is not already installed, also
# other more minor issues (installs junk, sandbox/offscreen issues)
RESTRICT="test"
-RDEPEND="~dev-qt/qtbase-${PV}:6[gui,network=,opengl=,sql?,ssl?,vulkan=,widgets=]"
+RDEPEND="~dev-qt/qtbase-${PV}:6[accessibility=,gui,network=,opengl=,sql?,ssl?,vulkan=,widgets=]"
DEPEND="
${RDEPEND}
vulkan? ( dev-util/vulkan-headers )