summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 15:22:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 15:27:31 +0100
commit19e245efc247c81e250e891045c7a9351434c9a5 (patch)
treebdc8919a5ed32805937a2e2913fcc2098c42aed0 /dev-qt/qtwebengine
parentnet-p2p/retroshare: avoid broken doxygen-1.8.16 (diff)
downloadgentoo-19e245efc247c81e250e891045c7a9351434c9a5.tar.gz
gentoo-19e245efc247c81e250e891045c7a9351434c9a5.tar.bz2
gentoo-19e245efc247c81e250e891045c7a9351434c9a5.zip
dev-qt: Drop Qt 5.12.3
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwebengine')
-rw-r--r--dev-qt/qtwebengine/Manifest1
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.12.0-nouveau-disable-gpu.patch98
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.12.5-pulseaudio-13.patch88
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.12.3.ebuild137
4 files changed, 0 insertions, 324 deletions
diff --git a/dev-qt/qtwebengine/Manifest b/dev-qt/qtwebengine/Manifest
index 1836986d3bc2..08509edb51c7 100644
--- a/dev-qt/qtwebengine/Manifest
+++ b/dev-qt/qtwebengine/Manifest
@@ -1,3 +1,2 @@
-DIST qtwebengine-everywhere-src-5.12.3.tar.xz 249275648 BLAKE2B 7d2404084a510c62b638dd09736130eeb40e494f9594339afc7df6628878aafed778a2785f6848702d51b3a4ef1dc8b333d5e5eeeeb8f930b4da839eb70bc175 SHA512 5b500ec6653aa6ed70e7826fe394f95c7932eaea5b1b48f6342a6f18294f75e4f954959fa2f42de0685097679389245d2bc80454e8eea202fa18a326d6d5a9a5
DIST qtwebengine-everywhere-src-5.13.2.tar.xz 255593964 BLAKE2B 458f718183aa53376e1aeeb6306b0b3960bd001aebf61e9650d30afd408af003183b7748a87aa0c6a1aa0b3a4be548b417609146b71dc6afa46db49c4b48919f SHA512 10ae5cca36230069ef117cae15b84e29124c43e4864dbfa7a1f99879764b871355281edcb1942e86ec3a4cac12bbfd2749577745c8c7e736eb6a9909876554d0
DIST qtwebengine-everywhere-src-5.14.1.tar.xz 242438244 BLAKE2B d24210b2e04522b27409cc5ccfe722114f711c1c5e9aaff76882c178b0c455b475b90fd2acd5f7ba4f5dfba85c228c4baf2c231d3661eadf83e984d7e7b9e30f SHA512 fafa2fbc789941e837e35945857a6da00e73bd2abe512290674b9957719b998d8b8b95a35c709a171c9d0d111e6f418cec630dfcdbe47ecbae25a3b94e4c99f9
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.12.0-nouveau-disable-gpu.patch b/dev-qt/qtwebengine/files/qtwebengine-5.12.0-nouveau-disable-gpu.patch
deleted file mode 100644
index ec315ca210e8..000000000000
--- a/dev-qt/qtwebengine/files/qtwebengine-5.12.0-nouveau-disable-gpu.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-From: Antonio Larrosa <alarrosa@suse.com>
-Subject: Disable GPU when using nouveau or running on wayland
-References: boo#1005323, boo#1060990
-
-Qt WebEngine uses multi-threaded OpenGL, which nouveau does not support.
-It also crashes when running on wayland, the cause is not yet known.
-Work around these issues by not doing GPU-accelerated rendering in such
-cases.
-
-Index: qtwebengine-everywhere-src-5.12.0-alpha/src/core/web_engine_context.cpp
-===================================================================
---- qtwebengine-everywhere-src-5.12.0-alpha.orig/src/core/web_engine_context.cpp
-+++ qtwebengine-everywhere-src-5.12.0-alpha/src/core/web_engine_context.cpp
-@@ -101,6 +101,7 @@
- #include <QOffscreenSurface>
- #ifndef QT_NO_OPENGL
- # include <QOpenGLContext>
-+# include <QOpenGLFunctions>
- #endif
- #include <QQuickWindow>
- #include <QStringList>
-@@ -162,6 +163,39 @@ void dummyGetPluginCallback(const std::v
- }
- #endif
-
-+#ifndef QT_NO_OPENGL
-+QString openGLVendor()
-+{
-+ QString vendor;
-+
-+ QOpenGLContext *oldContext = QOpenGLContext::currentContext();
-+ QSurface *oldSurface = 0;
-+ if (oldContext)
-+ oldSurface = oldContext->surface();
-+
-+ QScopedPointer<QOffscreenSurface> surface( new QOffscreenSurface );
-+ surface->create();
-+ QOpenGLContext context;
-+ if (!context.create()) {
-+ qDebug() << "Error creating openGL context";
-+ }
-+ else if (!context.makeCurrent(surface.data())) {
-+ qDebug() << "Error making openGL context current context";
-+ } else {
-+ const GLubyte *p;
-+ QOpenGLFunctions *f = context.functions();
-+ if ((p = f->glGetString(GL_VENDOR)))
-+ vendor = QString::fromLatin1(reinterpret_cast<const char *>(p));
-+ }
-+
-+ context.doneCurrent();
-+ if (oldContext && oldSurface)
-+ oldContext->makeCurrent(oldSurface);
-+
-+ return vendor;
-+}
-+#endif
-+
- } // namespace
-
- namespace QtWebEngineCore {
-@@ -440,6 +474,27 @@ WebEngineContext::WebEngineContext()
- const char *glType = 0;
- #ifndef QT_NO_OPENGL
-
-+ bool disableGpu = qEnvironmentVariableIsSet("QT_WEBENGINE_DISABLE_GPU");
-+
-+ if (!qEnvironmentVariableIsSet("QT_WEBENGINE_DISABLE_WAYLAND_WORKAROUND") && qApp->platformName().startsWith("wayland", Qt::CaseInsensitive))
-+ {
-+ qWarning() << "Running on wayland. Qt WebEngine will disable usage of the GPU.\n"
-+ "Note: you can set the QT_WEBENGINE_DISABLE_WAYLAND_WORKAROUND\n"
-+ "environment variable before running this application, but this is \n"
-+ "not recommended since this usually causes applications to crash.";
-+ disableGpu = true;
-+ }
-+
-+ if (!qEnvironmentVariableIsSet("QT_WEBENGINE_DISABLE_NOUVEAU_WORKAROUND") && openGLVendor() == QStringLiteral("nouveau"))
-+ {
-+ qWarning() << "Nouveau openGL driver detected. Qt WebEngine will disable usage of the GPU.\n"
-+ "Note: you can set the QT_WEBENGINE_DISABLE_NOUVEAU_WORKAROUND\n"
-+ "environment variable before running this application, but this is \n"
-+ "not recommended since this usually causes applications to crash as\n"
-+ "Nouveau openGL drivers don't support multithreaded rendering";
-+ disableGpu = true;
-+ }
-+
- bool tryGL =
- !usingANGLE()
- && (!usingSoftwareDynamicGL()
-@@ -450,7 +505,7 @@ WebEngineContext::WebEngineContext()
- || enableWebGLSoftwareRendering
- #endif
- )
-- && !usingQtQuick2DRenderer();
-+ && !usingQtQuick2DRenderer() && !disableGpu;
-
- if (tryGL) {
- if (qt_gl_global_share_context() && qt_gl_global_share_context()->isValid()) {
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.12.5-pulseaudio-13.patch b/dev-qt/qtwebengine/files/qtwebengine-5.12.5-pulseaudio-13.patch
deleted file mode 100644
index 1e57f0ed8349..000000000000
--- a/dev-qt/qtwebengine/files/qtwebengine-5.12.5-pulseaudio-13.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From 7ac85fb4cc6f44a21761a591ac497ae3d6bf966d Mon Sep 17 00:00:00 2001
-From: Allan Sandfeld Jensen <allan.jensen@qt.io>
-Date: Mon, 23 Sep 2019 13:49:53 +0200
-Subject: [PATCH] Fix building with pulseaudio 13
-MIME-Version: 1.0
-Content-Type: text/plain; charset=utf8
-Content-Transfer-Encoding: 8bit
-
-The function signature changed though the ABI stayed the same.
-
-Change-Id: I86ca361b5e4f0c523e1031910df438c23beee876
-Fixes: QTBUG-77037
-Reviewed-by: Jüri Valdmann <juri.valdmann@qt.io>
----
- src/3rdparty/chromium/media/audio/pulse/pulse.sigs | 16 ++++++++--------
- src/3rdparty/chromium/media/audio/pulse/pulse_stub_header.fragment | 11 +++++++++++
- 2 files changed, 19 insertions(+), 8 deletions(-)
-
-diff --git a/src/3rdparty/chromium/media/audio/pulse/pulse.sigs b/src/3rdparty/chromium/media/audio/pulse/pulse.sigs
-index 8b5888786a9..daaeb149c13 100644
---- a/src/3rdparty/chromium/media/audio/pulse/pulse.sigs
-+++ b/src/3rdparty/chromium/media/audio/pulse/pulse.sigs
-@@ -24,11 +24,11 @@ pa_operation* pa_context_get_source_info_by_index(pa_context* c, uint32_t idx, p
- pa_operation* pa_context_get_source_info_by_name(pa_context* c, const char* name, pa_source_info_cb_t cb, void *userdata);
- pa_operation* pa_context_get_source_info_list(pa_context* c, pa_source_info_cb_t cb, void* userdata);
- pa_operation* pa_context_get_sink_info_list(pa_context* c, pa_sink_info_cb_t cb, void* userdata);
--pa_context_state_t pa_context_get_state(pa_context* c);
-+pa_context_state_t pa_context_get_state(const_pa_context_ptr c);
- pa_context* pa_context_new(pa_mainloop_api* mainloop, const char* name);
- pa_operation* pa_context_set_source_volume_by_index(pa_context* c, uint32_t idx, const pa_cvolume* volume, pa_context_success_cb_t cb, void* userdata);
- void pa_context_set_state_callback(pa_context* c, pa_context_notify_cb_t cb, void* userdata);
--pa_operation_state_t pa_operation_get_state(pa_operation* o);
-+pa_operation_state_t pa_operation_get_state(const_pa_operation_ptr o);
- void pa_context_unref(pa_context* c);
- void pa_operation_unref(pa_operation* o);
- int pa_stream_begin_write(pa_stream* p, void** data, size_t* nbytes);
-@@ -38,23 +38,23 @@ pa_operation* pa_stream_cork(pa_stream* s, int b, pa_stream_success_cb_t cb, voi
- int pa_stream_disconnect(pa_stream* s);
- int pa_stream_drop(pa_stream *p);
- pa_operation* pa_stream_flush(pa_stream* s, pa_stream_success_cb_t cb, void* userdata);
--uint32_t pa_stream_get_device_index(pa_stream* s);
-+uint32_t pa_stream_get_device_index(const_pa_stream_ptr s);
- int pa_stream_get_latency(pa_stream* s, pa_usec_t* r_usec, int* negative);
--pa_stream_state_t pa_stream_get_state(pa_stream* p);
-+pa_stream_state_t pa_stream_get_state(const_pa_stream_ptr p);
- pa_stream* pa_stream_new(pa_context* c, const char* name, const pa_sample_spec* ss, const pa_channel_map * map);
- pa_stream* pa_stream_new_with_proplist(pa_context* c, const char* name, const pa_sample_spec* ss, const pa_channel_map* map, pa_proplist* p);
- pa_proplist* pa_proplist_new(void);
--int pa_proplist_contains(pa_proplist* p, const char* key);
-+int pa_proplist_contains(const_pa_proplist_ptr p, const char* key);
- void pa_proplist_free(pa_proplist* p);
--const char* pa_proplist_gets(pa_proplist* p, const char* key);
-+const char* pa_proplist_gets(const_pa_proplist_ptr p, const char* key);
- int pa_proplist_sets(pa_proplist* p, const char* key, const char* value);
--size_t pa_stream_readable_size(pa_stream *p);
-+size_t pa_stream_readable_size(const_pa_stream_ptr p);
- int pa_stream_peek(pa_stream* p, const void** data, size_t* nbytes);
- void pa_stream_set_read_callback(pa_stream* p, pa_stream_request_cb_t cb, void* userdata);
- void pa_stream_set_state_callback(pa_stream* s, pa_stream_notify_cb_t cb, void* userdata);
- int pa_stream_write(pa_stream* p, const void* data, size_t nbytes, pa_free_cb_t free_cb, int64_t offset, pa_seek_mode_t seek);
- void pa_stream_set_write_callback(pa_stream *p, pa_stream_request_cb_t cb, void *userdata);
- void pa_stream_unref(pa_stream* s);
--int pa_context_errno(pa_context *c);
-+int pa_context_errno(const_pa_context_ptr c);
- const char* pa_strerror(int error);
- pa_cvolume* pa_cvolume_set(pa_cvolume* a, unsigned channels, pa_volume_t v);
-diff --git a/src/3rdparty/chromium/media/audio/pulse/pulse_stub_header.fragment b/src/3rdparty/chromium/media/audio/pulse/pulse_stub_header.fragment
-index 2a2d3e7552b..cdaa841b29f 100644
---- a/src/3rdparty/chromium/media/audio/pulse/pulse_stub_header.fragment
-+++ b/src/3rdparty/chromium/media/audio/pulse/pulse_stub_header.fragment
-@@ -5,4 +5,15 @@ extern "C" {
-
- #include <pulse/pulseaudio.h>
-
-+#if PA_MAJOR > 12
-+typedef const pa_context* const_pa_context_ptr;
-+typedef const pa_operation* const_pa_operation_ptr;
-+typedef const pa_proplist* const_pa_proplist_ptr;
-+typedef const pa_stream* const_pa_stream_ptr;
-+#else
-+typedef pa_context* const_pa_context_ptr;
-+typedef pa_operation* const_pa_operation_ptr;
-+typedef pa_proplist* const_pa_proplist_ptr;
-+typedef pa_stream* const_pa_stream_ptr;
-+#endif
- }
---
-2.16.3
diff --git a/dev-qt/qtwebengine/qtwebengine-5.12.3.ebuild b/dev-qt/qtwebengine/qtwebengine-5.12.3.ebuild
deleted file mode 100644
index ec2e98d5c56a..000000000000
--- a/dev-qt/qtwebengine/qtwebengine-5.12.3.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-inherit multiprocessing python-any-r1 qt5-build
-
-DESCRIPTION="Library for rendering dynamic web content in Qt5 C++ and QML applications"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="x86"
-fi
-
-IUSE="alsa bindist designer geolocation jumbo-build pulseaudio +system-ffmpeg +system-icu widgets"
-REQUIRED_USE="designer? ( widgets )"
-
-RDEPEND="
- app-arch/snappy:=
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qtprintsupport-${PV}
- ~dev-qt/qtwebchannel-${PV}[qml]
- dev-libs/expat
- dev-libs/libevent:=
- dev-libs/libxml2[icu]
- dev-libs/libxslt
- dev-libs/re2:=
- media-libs/fontconfig
- media-libs/freetype
- media-libs/harfbuzz:=
- media-libs/lcms:2
- media-libs/libjpeg-turbo:=
- media-libs/libpng:0=
- >=media-libs/libvpx-1.5:=[svc]
- media-libs/libwebp:=
- media-libs/mesa[egl,X(+)]
- media-libs/opus
- sys-apps/dbus
- sys-apps/pciutils
- sys-libs/zlib[minizip]
- virtual/libudev
- x11-libs/libdrm
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXcursor
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXi
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/libXScrnSaver
- x11-libs/libXtst
- alsa? ( media-libs/alsa-lib )
- designer? ( ~dev-qt/designer-${PV} )
- geolocation? ( ~dev-qt/qtpositioning-${PV} )
- pulseaudio? ( media-sound/pulseaudio:= )
- system-ffmpeg? ( media-video/ffmpeg:0= )
- system-icu? ( >=dev-libs/icu-60.2:= )
- widgets? (
- ~dev-qt/qtdeclarative-${PV}[widgets]
- ~dev-qt/qtwidgets-${PV}
- )
-"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- >=app-arch/gzip-1.7
- dev-util/gperf
- dev-util/ninja
- dev-util/re2c
- sys-devel/bison
- !!=sys-devel/binutils-2.31.1-r5
- !!=sys-devel/binutils-2.32-r0
-"
-
-PATCHES+=(
- "${FILESDIR}/${PN}-5.12.0-nouveau-disable-gpu.patch" # bug 609752
- "${FILESDIR}/${PN}-5.12.5-pulseaudio-13.patch" # bug 694960, 705434
- "${FILESDIR}/${PN}-5.12.5-icu-65.patch"
-)
-
-src_prepare() {
- if ! use jumbo-build; then
- sed -i -e 's|use_jumbo_build=true|use_jumbo_build=false|' \
- src/core/config/common.pri || die
- fi
-
- # bug 620444 - ensure local headers are used
- find "${S}" -type f -name "*.pr[fio]" | xargs sed -i -e 's|INCLUDEPATH += |&$$QTWEBENGINE_ROOT/include |' || die
-
- qt_use_disable_config alsa webengine-alsa src/core/config/linux.pri
- qt_use_disable_config pulseaudio webengine-pulseaudio src/core/config/linux.pri
-
- qt_use_disable_mod designer webenginewidgets src/plugins/plugins.pro
-
- qt_use_disable_mod geolocation positioning \
- mkspecs/features/configure.prf \
- src/core/core_chromium.pri \
- src/core/core_common.pri
-
- qt_use_disable_mod widgets widgets src/src.pro
-
- qt5-build_src_prepare
-}
-
-src_configure() {
- export NINJA_PATH=/usr/bin/ninja
- export NINJAFLAGS="${NINJAFLAGS:--j$(makeopts_jobs) -l$(makeopts_loadavg "${MAKEOPTS}" 0) -v}"
-
- local myqmakeargs=(
- --
- -opus
- -printing-and-pdf
- -webp
- $(usex alsa '-alsa' '')
- $(usex bindist '' '-proprietary-codecs')
- $(usex pulseaudio '-pulseaudio' '')
- $(usex system-ffmpeg '-ffmpeg' '')
- $(usex system-icu '-webengine-icu' '')
- )
- qt5-build_src_configure
-}
-
-src_install() {
- qt5-build_src_install
-
- # bug 601472
- if [[ ! -f ${D%/}${QT5_LIBDIR}/libQt5WebEngine.so ]]; then
- die "${CATEGORY}/${PF} failed to build anything. Please report to https://bugs.gentoo.org/"
- fi
-}