summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-27 03:09:00 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-27 03:25:50 -0400
commit7d71cb6af880c865502af5e83cbfa001fa147489 (patch)
tree9fb7b25ed2a5ec20445e1a8d757fe2850bd23af1 /dev-qt/qtscxml
parentdev-qt/qtquicktimeline: add 6.7.3 (diff)
downloadgentoo-7d71cb6af880c865502af5e83cbfa001fa147489.tar.gz
gentoo-7d71cb6af880c865502af5e83cbfa001fa147489.tar.bz2
gentoo-7d71cb6af880c865502af5e83cbfa001fa147489.zip
dev-qt/qtscxml: add 6.7.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtscxml')
-rw-r--r--dev-qt/qtscxml/Manifest1
-rw-r--r--dev-qt/qtscxml/qtscxml-6.7.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/Manifest b/dev-qt/qtscxml/Manifest
index 2932bb3fd583..6b938fef4af4 100644
--- a/dev-qt/qtscxml/Manifest
+++ b/dev-qt/qtscxml/Manifest
@@ -1,3 +1,4 @@
DIST qtscxml-everywhere-opensource-src-5.15.14.tar.xz 429224 BLAKE2B 67936258bfb67bddf5b711bc97bebb123f56d8f7dca9b46424a33d1205b0a3a6dfc89ae7bc429ffedb928d4f1b88c62abdabee301c09a0e3b0bf65128f174d67 SHA512 1490824b0108300b1924f404431e3871ce067def15993aed9af768c871b3d0eae4cd0b8f467671d3ebcada98d5e11dfe86e250467b7dbf9708ce9f37766861d5
DIST qtscxml-everywhere-src-6.7.2.tar.xz 1168452 BLAKE2B 7cb06fd09758aaea28ccada62aa51b427c265416afa3f152601cadd1c9586050e87d36f8cf9679ca3ef83777bfec1119d861bd9491a176460d58beb5376e4ce4 SHA512 4eba366c2c10593cfc0fdeeff92aa9951b838837cacf113bf849b5da68da4d41d550490bc4be28620f766ab412ca4066c71ee7a1ff18651dd08267b01df6c2fe
+DIST qtscxml-everywhere-src-6.7.3.tar.xz 1168340 BLAKE2B 3082ed9be66233a53ec99a684c87c9211b8805f9dd6967f9e0b7b509d0fb809704d39e0c688e039103cc36f4ad0f4aef39823b3b57e16b67126c9772b5fd7754 SHA512 d2d561f7a94d1fad2ad578b602c51c5f506bb0ea2c145647ea490399bac5995191c56ad62454775f15a2d3973e99cd220487ead3d5873163949b9ddd58bdada7
DIST qtscxml-everywhere-src-6.8.0-rc.tar.xz 556928 BLAKE2B 64f8d88845dcc240a2a833f1220e72cccec44d8fafea8ed983b8819aa4b2d82b661ed3ba8823d13aa1adf606d64848bef28340561fca709453bca9ebac4d083d SHA512 5c91d68e673ea50c4a7cc0d1fc5a1eb69e43bacdf8eee337206c10fbd8c21f2375a315bd2c38544313f2c012b85c21fbc596503c79a12572ddb9513a11aaedb9
diff --git a/dev-qt/qtscxml/qtscxml-6.7.3.ebuild b/dev-qt/qtscxml/qtscxml-6.7.3.ebuild
new file mode 100644
index 000000000000..0f087eb496fc
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.7.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, considering this flaky)
+ tst_qstatemachine
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ )
+
+ qt6-build_src_configure
+}