summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-12-15 01:43:11 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-12-15 15:17:33 -0500
commit30a64c3de8a71769cce2e18849003417c12495bd (patch)
treedabb92faeaa374f8715784025e301c8c98baadf9 /dev-qt/qtscxml
parentdev-qt/qtremoteobjects: add 6.9.9999 (diff)
downloadgentoo-30a64c3de8a71769cce2e18849003417c12495bd.tar.gz
gentoo-30a64c3de8a71769cce2e18849003417c12495bd.tar.bz2
gentoo-30a64c3de8a71769cce2e18849003417c12495bd.zip
dev-qt/qtscxml: add 6.9.9999
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtscxml')
-rw-r--r--dev-qt/qtscxml/qtscxml-6.9.9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/qtscxml-6.9.9999.ebuild b/dev-qt/qtscxml/qtscxml-6.9.9999.ebuild
new file mode 100644
index 000000000000..0f087eb496fc
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.9.9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, considering this flaky)
+ tst_qstatemachine
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ )
+
+ qt6-build_src_configure
+}