summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-16 05:51:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-16 06:18:55 +0200
commitff60f18ffa7987e8bce7dce6e7f9c39c7b10f9a4 (patch)
tree591a9f87bb80fb895cc8a811588be4468f696ab1 /dev-python
parentdev-python/sqlalchemy: Bump to 2.0.20 (diff)
downloadgentoo-ff60f18ffa7987e8bce7dce6e7f9c39c7b10f9a4.tar.gz
gentoo-ff60f18ffa7987e8bce7dce6e7f9c39c7b10f9a4.tar.bz2
gentoo-ff60f18ffa7987e8bce7dce6e7f9c39c7b10f9a4.zip
dev-python/awxkit: Bump to 22.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/awxkit/Manifest1
-rw-r--r--dev-python/awxkit/awxkit-22.7.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/awxkit/Manifest b/dev-python/awxkit/Manifest
index 414253df5f78..49aba60bdf21 100644
--- a/dev-python/awxkit/Manifest
+++ b/dev-python/awxkit/Manifest
@@ -1,2 +1,3 @@
DIST awx-22.5.0.gh.tar.gz 17629249 BLAKE2B 28e560b36fc16173e8b1e0e2dfbab7a30082e2d3cde40c63a557a30772fce5a03657e57b1cb1de13bf358731d31caee670424ed264ae3ef6aeaff01120fef7a1 SHA512 630c94e747e21e55f32c2f96704ced8ac0214c3869149ad726ac2d4386d3ef7643990b4c07d23201c9191b97bce25b81330581184e040bce6efa341163f74ef7
DIST awx-22.6.0.gh.tar.gz 17639868 BLAKE2B 8733d1d81c099a56873bea0f38cafe696c70ae4f9274bee644b82b414317cdc537e22a1beea74d566e07cef4e5f5d3adea66a715f43dc30faab35cea1ee4616f SHA512 05fbe7dcc84902eadb40d8a55cc4022aaeedd015534a4caa379cd68684f96422674677c724e8473b0133f9986ae46a7a4a06649a60c8701bd202bc7d684ec972
+DIST awx-22.7.0.gh.tar.gz 17645480 BLAKE2B 06d4da9090db221ab23e86c8a8fc3e548437dc7903b4c05e09fbbbd3fc5254c528f3da0c41895533cb0615c863a1a940d3d254f52142e321243aa3113ce65187 SHA512 811976debbef72d0dce16caae1f6d19acafde5b7c15bfba9fdef3c5cfa0a2a06c30fbce81b52f0f1f63466d0cd8e6021e62819f5d134a59333d2331df42983eb
diff --git a/dev-python/awxkit/awxkit-22.7.0.ebuild b/dev-python/awxkit/awxkit-22.7.0.ebuild
new file mode 100644
index 000000000000..52670ed68dde
--- /dev/null
+++ b/dev-python/awxkit/awxkit-22.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1
+
+MY_P=awx-${PV}
+DESCRIPTION="Command line interface for Ansible AWX"
+HOMEPAGE="
+ https://github.com/ansible/awx/
+ https://pypi.org/project/awxkit/
+"
+# no sdist, as of 22.0.0
+SRC_URI="
+ https://github.com/ansible/awx/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/awxkit"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+ printf '%s\n' "${PV}" > VERSION || die
+
+ sed -e 's|websocket-client==[[:digit:]\.]*|websocket-client|' \
+ -e "/'clean'/d" \
+ -i setup.py || die
+ distutils-r1_src_prepare
+}