summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-27 21:18:29 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-27 22:18:25 +0100
commitcc989b91c9e8ca7ec211c1d7f9f66331fcf015b8 (patch)
tree4b1bc33d020e3c83863d68d45b62218b26e539cb /dev-python
parentdev-python/sphinx: Bump to 4.3.1 (diff)
downloadgentoo-cc989b91c9e8ca7ec211c1d7f9f66331fcf015b8.tar.gz
gentoo-cc989b91c9e8ca7ec211c1d7f9f66331fcf015b8.tar.bz2
gentoo-cc989b91c9e8ca7ec211c1d7f9f66331fcf015b8.zip
dev-python/aiofiles: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aiofiles/Manifest1
-rw-r--r--dev-python/aiofiles/aiofiles-0.8.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/aiofiles/Manifest b/dev-python/aiofiles/Manifest
index f7c707c9df6f..a40abbde07b6 100644
--- a/dev-python/aiofiles/Manifest
+++ b/dev-python/aiofiles/Manifest
@@ -1 +1,2 @@
DIST aiofiles-0.7.0.tar.gz 23245 BLAKE2B 5dcb743912555de9a4c58a37925ca08c4be7065ea78924854d548b32f31f93bdf1b231db840aa9ac822d467ffd8c7f57c506c5f6d550c662013008899da8b716 SHA512 75287266cd86c572db0795074d625dac8b3476c4d8ef9a193ce01ce80a423a4aa39f6e5ec5005fb441375ccb2a2ec84913634919ee5000bfb7623ac77a030b92
+DIST aiofiles-0.8.0.tar.gz 24139 BLAKE2B 0f113b75832219e63c0894e70ec613138db7e243ad032bc6d7bf715aab505b5246ab7a0add64b46a9b981801cf05885f7affa965cb625941dc57b805280f0ff1 SHA512 4f590baa0369d465a6139c0d4f50beeec60f8f213b607e0e41598f45f507a12edc67b29c77718b03eee7532f10ead8599f55aac3fcb78d0429435c25a58f6d2e
diff --git a/dev-python/aiofiles/aiofiles-0.8.0.ebuild b/dev-python/aiofiles/aiofiles-0.8.0.ebuild
new file mode 100644
index 000000000000..ea78ba811a39
--- /dev/null
+++ b/dev-python/aiofiles/aiofiles-0.8.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="File support for asyncio"
+HOMEPAGE="https://github.com/Tinche/aiofiles"
+SRC_URI="https://github.com/Tinche/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest