summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-20 12:04:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-20 12:04:12 +0100
commit91951f3adb95bb3e2f5aa2f7555b0743dcda2d5b (patch)
tree7ca03e8a64c6908156f3f1c641d00a4c26fe2253 /dev-python
parentdev-python/time-machine: Remove old (diff)
downloadgentoo-91951f3adb95bb3e2f5aa2f7555b0743dcda2d5b.tar.gz
gentoo-91951f3adb95bb3e2f5aa2f7555b0743dcda2d5b.tar.bz2
gentoo-91951f3adb95bb3e2f5aa2f7555b0743dcda2d5b.zip
dev-python/pytest-rerunfailures: Bump to 15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-rerunfailures/Manifest1
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-15.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/Manifest b/dev-python/pytest-rerunfailures/Manifest
index 9205122c4b3e..80ec500c84e7 100644
--- a/dev-python/pytest-rerunfailures/Manifest
+++ b/dev-python/pytest-rerunfailures/Manifest
@@ -1 +1,2 @@
DIST pytest-rerunfailures-14.0.tar.gz 21350 BLAKE2B bb273d77a732c0296ca041b4cbd91fd48052076e9f76839b862b03de9f448208a216483bc486f23542cd99a12ef2934a46e3ea4162ca87bfd5c0904f2d114179 SHA512 8aa23a57206b0e6af133c716517c3c96cc156cc2f86b06c0fa80e9fea2b11f32e98cfb41f6a5fb05b38bab7496258160ba42fe6ae00d7bef8024159a8ed4a3f5
+DIST pytest-rerunfailures-15.0.tar.gz 21816 BLAKE2B 75c42cec3a9cc0208e045be82c1b6660d56fff898ac0e97e992a020229a095a619eb1e87eeca8af7fba4f455f044ddd9729943becd90d185356e7bddb9ab1c6b SHA512 c03f430f9e24e0b149391e08ae6f38450d731d1f6a28294173e75f8776dc596230422e2082bbbc74cf31ea7e4c3105f5d8d57825dc418c4ce1c5538d84c861c3
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-15.0.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-15.0.ebuild
new file mode 100644
index 000000000000..74f5be166cc3
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-15.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-rerunfailures/
+ https://pypi.org/project/pytest-rerunfailures/
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_rerunfailures
+ epytest
+}