summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-08 19:15:19 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-08 19:15:19 +0100
commit746be01ea417ababe2cfeeaa34e656aad8fa58f9 (patch)
treec1978c82cf6ad2ac58e06a46d8c64fb2b078b384 /dev-python
parentdev-python/redis-py: Set MY_P to prepare for rename (diff)
downloadgentoo-746be01ea417ababe2cfeeaa34e656aad8fa58f9.tar.gz
gentoo-746be01ea417ababe2cfeeaa34e656aad8fa58f9.tar.bz2
gentoo-746be01ea417ababe2cfeeaa34e656aad8fa58f9.zip
Rename dev-python/{redis-py → redis}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cachelib/cachelib-0.10.1.ebuild2
-rw-r--r--dev-python/cachelib/cachelib-0.10.2.ebuild2
-rw-r--r--dev-python/cachelib/cachelib-0.9.0.ebuild2
-rw-r--r--dev-python/django-cacheops/django-cacheops-6.1.ebuild2
-rw-r--r--dev-python/django-redis/django-redis-5.2.0.ebuild2
-rw-r--r--dev-python/fakeredis/fakeredis-2.4.0.ebuild4
-rw-r--r--dev-python/fakeredis/fakeredis-2.5.0.ebuild4
-rw-r--r--dev-python/fakeredis/fakeredis-2.6.0.ebuild4
-rw-r--r--dev-python/fakeredis/fakeredis-2.7.0.ebuild4
-rw-r--r--dev-python/fakeredis/fakeredis-2.7.1.ebuild4
-rw-r--r--dev-python/kombu/kombu-5.3.0_beta2.ebuild4
-rw-r--r--dev-python/logutils/logutils-0.3.5-r1.ebuild2
-rw-r--r--dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild2
-rw-r--r--dev-python/redis/Manifest (renamed from dev-python/redis-py/Manifest)0
-rw-r--r--dev-python/redis/metadata.xml (renamed from dev-python/redis-py/metadata.xml)0
-rw-r--r--dev-python/redis/redis-4.4.0.ebuild (renamed from dev-python/redis-py/redis-py-4.4.0.ebuild)0
-rw-r--r--dev-python/redis/redis-4.4.1.ebuild (renamed from dev-python/redis-py/redis-py-4.4.1.ebuild)0
-rw-r--r--dev-python/redis/redis-4.4.2.ebuild (renamed from dev-python/redis-py/redis-py-4.4.2.ebuild)0
-rw-r--r--dev-python/redis/redis-4.5.0.ebuild (renamed from dev-python/redis-py/redis-py-4.5.0.ebuild)0
-rw-r--r--dev-python/redis/redis-4.5.1.ebuild (renamed from dev-python/redis-py/redis-py-4.5.1.ebuild)0
-rw-r--r--dev-python/requests-cache/requests-cache-0.9.7.ebuild2
-rw-r--r--dev-python/requests-cache/requests-cache-0.9.8.ebuild2
-rw-r--r--dev-python/rq/rq-1.11.1.ebuild2
-rw-r--r--dev-python/rq/rq-1.12.0.ebuild2
-rw-r--r--dev-python/spotipy/spotipy-2.22.1.ebuild2
25 files changed, 24 insertions, 24 deletions
diff --git a/dev-python/cachelib/cachelib-0.10.1.ebuild b/dev-python/cachelib/cachelib-0.10.1.ebuild
index 74784a2e4520..f6bfe1cc57da 100644
--- a/dev-python/cachelib/cachelib-0.10.1.ebuild
+++ b/dev-python/cachelib/cachelib-0.10.1.ebuild
@@ -27,7 +27,7 @@ BDEPEND="
dev-db/redis
dev-python/pylibmc[${PYTHON_USEDEP}]
dev-python/pytest-xprocess[${PYTHON_USEDEP}]
- dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
net-misc/memcached
www-servers/uwsgi[python,${PYTHON_USEDEP}]
)
diff --git a/dev-python/cachelib/cachelib-0.10.2.ebuild b/dev-python/cachelib/cachelib-0.10.2.ebuild
index 74784a2e4520..f6bfe1cc57da 100644
--- a/dev-python/cachelib/cachelib-0.10.2.ebuild
+++ b/dev-python/cachelib/cachelib-0.10.2.ebuild
@@ -27,7 +27,7 @@ BDEPEND="
dev-db/redis
dev-python/pylibmc[${PYTHON_USEDEP}]
dev-python/pytest-xprocess[${PYTHON_USEDEP}]
- dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
net-misc/memcached
www-servers/uwsgi[python,${PYTHON_USEDEP}]
)
diff --git a/dev-python/cachelib/cachelib-0.9.0.ebuild b/dev-python/cachelib/cachelib-0.9.0.ebuild
index eedabefc93fa..093fd6a9110b 100644
--- a/dev-python/cachelib/cachelib-0.9.0.ebuild
+++ b/dev-python/cachelib/cachelib-0.9.0.ebuild
@@ -27,7 +27,7 @@ BDEPEND="
dev-db/redis
dev-python/pylibmc[${PYTHON_USEDEP}]
dev-python/pytest-xprocess[${PYTHON_USEDEP}]
- dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
net-misc/memcached
www-servers/uwsgi[python,${PYTHON_USEDEP}]
)
diff --git a/dev-python/django-cacheops/django-cacheops-6.1.ebuild b/dev-python/django-cacheops/django-cacheops-6.1.ebuild
index be9d776c6021..8533afc768b7 100644
--- a/dev-python/django-cacheops/django-cacheops-6.1.ebuild
+++ b/dev-python/django-cacheops/django-cacheops-6.1.ebuild
@@ -26,7 +26,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/django-1.8[${PYTHON_USEDEP}]
- >=dev-python/redis-py-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/redis-2.9.1[${PYTHON_USEDEP}]
>=dev-python/funcy-1.8[${PYTHON_USEDEP}]
>=dev-python/six-1.4.0[${PYTHON_USEDEP}]
"
diff --git a/dev-python/django-redis/django-redis-5.2.0.ebuild b/dev-python/django-redis/django-redis-5.2.0.ebuild
index e030bba9701e..d4b717c47492 100644
--- a/dev-python/django-redis/django-redis-5.2.0.ebuild
+++ b/dev-python/django-redis/django-redis-5.2.0.ebuild
@@ -16,7 +16,7 @@ KEYWORDS="~amd64"
RDEPEND="
>=dev-python/django-2.2[${PYTHON_USEDEP}]
- >=dev-python/redis-py-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-3.0.0[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
diff --git a/dev-python/fakeredis/fakeredis-2.4.0.ebuild b/dev-python/fakeredis/fakeredis-2.4.0.ebuild
index 407a0ae4ef68..3e6baad1f89d 100644
--- a/dev-python/fakeredis/fakeredis-2.4.0.ebuild
+++ b/dev-python/fakeredis/fakeredis-2.4.0.ebuild
@@ -25,8 +25,8 @@ SLOT="0"
KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
RDEPEND="
- >=dev-python/redis-py-4.2[${PYTHON_USEDEP}]
- <dev-python/redis-py-4.5[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/redis-4.5[${PYTHON_USEDEP}]
>=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
"
BDEPEND="
diff --git a/dev-python/fakeredis/fakeredis-2.5.0.ebuild b/dev-python/fakeredis/fakeredis-2.5.0.ebuild
index 4186af5980d2..1d470272a507 100644
--- a/dev-python/fakeredis/fakeredis-2.5.0.ebuild
+++ b/dev-python/fakeredis/fakeredis-2.5.0.ebuild
@@ -25,8 +25,8 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
RDEPEND="
- >=dev-python/redis-py-4.2[${PYTHON_USEDEP}]
- <dev-python/redis-py-4.5[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/redis-4.5[${PYTHON_USEDEP}]
>=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
"
BDEPEND="
diff --git a/dev-python/fakeredis/fakeredis-2.6.0.ebuild b/dev-python/fakeredis/fakeredis-2.6.0.ebuild
index 4186af5980d2..1d470272a507 100644
--- a/dev-python/fakeredis/fakeredis-2.6.0.ebuild
+++ b/dev-python/fakeredis/fakeredis-2.6.0.ebuild
@@ -25,8 +25,8 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
RDEPEND="
- >=dev-python/redis-py-4.2[${PYTHON_USEDEP}]
- <dev-python/redis-py-4.5[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/redis-4.5[${PYTHON_USEDEP}]
>=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
"
BDEPEND="
diff --git a/dev-python/fakeredis/fakeredis-2.7.0.ebuild b/dev-python/fakeredis/fakeredis-2.7.0.ebuild
index 4186af5980d2..1d470272a507 100644
--- a/dev-python/fakeredis/fakeredis-2.7.0.ebuild
+++ b/dev-python/fakeredis/fakeredis-2.7.0.ebuild
@@ -25,8 +25,8 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
RDEPEND="
- >=dev-python/redis-py-4.2[${PYTHON_USEDEP}]
- <dev-python/redis-py-4.5[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/redis-4.5[${PYTHON_USEDEP}]
>=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
"
BDEPEND="
diff --git a/dev-python/fakeredis/fakeredis-2.7.1.ebuild b/dev-python/fakeredis/fakeredis-2.7.1.ebuild
index 4186af5980d2..1d470272a507 100644
--- a/dev-python/fakeredis/fakeredis-2.7.1.ebuild
+++ b/dev-python/fakeredis/fakeredis-2.7.1.ebuild
@@ -25,8 +25,8 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
RDEPEND="
- >=dev-python/redis-py-4.2[${PYTHON_USEDEP}]
- <dev-python/redis-py-4.5[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/redis-4.5[${PYTHON_USEDEP}]
>=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
"
BDEPEND="
diff --git a/dev-python/kombu/kombu-5.3.0_beta2.ebuild b/dev-python/kombu/kombu-5.3.0_beta2.ebuild
index fd7cbf3cfe64..9210dada0871 100644
--- a/dev-python/kombu/kombu-5.3.0_beta2.ebuild
+++ b/dev-python/kombu/kombu-5.3.0_beta2.ebuild
@@ -41,7 +41,7 @@ BDEPEND="
dev-python/python-zstandard[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
- >=dev-python/redis-py-4.2.2[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2.2[${PYTHON_USEDEP}]
dev-python/sqlalchemy[${PYTHON_USEDEP}]
)
"
@@ -85,7 +85,7 @@ pkg_postinst() {
optfeature "Etcd backend" dev-python/python-etcd
optfeature "MongoDB backend" dev-python/pymongo
optfeature "Pyro 4 backend" dev-python/Pyro4
- optfeature "Redis backend" dev-python/redis-py
+ optfeature "Redis backend" dev-python/redis
optfeature "sqlalchemy backend" dev-python/sqlalchemy
optfeature "yaml backend" dev-python/pyyaml
optfeature "MessagePack (de)serializer for Python" dev-python/msgpack
diff --git a/dev-python/logutils/logutils-0.3.5-r1.ebuild b/dev-python/logutils/logutils-0.3.5-r1.ebuild
index 95e63b27ac4c..2bcc1e0d8384 100644
--- a/dev-python/logutils/logutils-0.3.5-r1.ebuild
+++ b/dev-python/logutils/logutils-0.3.5-r1.ebuild
@@ -19,7 +19,7 @@ KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
BDEPEND="
test? (
dev-db/redis
- dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
)
"
diff --git a/dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild b/dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild
index f04b57aebe33..3d5ec115929c 100644
--- a/dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild
+++ b/dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild
@@ -19,7 +19,7 @@ KEYWORDS="~amd64"
RDEPEND="
dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
"
BDEPEND="test? (
diff --git a/dev-python/redis-py/Manifest b/dev-python/redis/Manifest
index ea7c553df02a..ea7c553df02a 100644
--- a/dev-python/redis-py/Manifest
+++ b/dev-python/redis/Manifest
diff --git a/dev-python/redis-py/metadata.xml b/dev-python/redis/metadata.xml
index 998ac9ce8e08..998ac9ce8e08 100644
--- a/dev-python/redis-py/metadata.xml
+++ b/dev-python/redis/metadata.xml
diff --git a/dev-python/redis-py/redis-py-4.4.0.ebuild b/dev-python/redis/redis-4.4.0.ebuild
index 320d50b908dc..320d50b908dc 100644
--- a/dev-python/redis-py/redis-py-4.4.0.ebuild
+++ b/dev-python/redis/redis-4.4.0.ebuild
diff --git a/dev-python/redis-py/redis-py-4.4.1.ebuild b/dev-python/redis/redis-4.4.1.ebuild
index d8eddff68492..d8eddff68492 100644
--- a/dev-python/redis-py/redis-py-4.4.1.ebuild
+++ b/dev-python/redis/redis-4.4.1.ebuild
diff --git a/dev-python/redis-py/redis-py-4.4.2.ebuild b/dev-python/redis/redis-4.4.2.ebuild
index d8eddff68492..d8eddff68492 100644
--- a/dev-python/redis-py/redis-py-4.4.2.ebuild
+++ b/dev-python/redis/redis-4.4.2.ebuild
diff --git a/dev-python/redis-py/redis-py-4.5.0.ebuild b/dev-python/redis/redis-4.5.0.ebuild
index d8eddff68492..d8eddff68492 100644
--- a/dev-python/redis-py/redis-py-4.5.0.ebuild
+++ b/dev-python/redis/redis-4.5.0.ebuild
diff --git a/dev-python/redis-py/redis-py-4.5.1.ebuild b/dev-python/redis/redis-4.5.1.ebuild
index d8eddff68492..d8eddff68492 100644
--- a/dev-python/redis-py/redis-py-4.5.1.ebuild
+++ b/dev-python/redis/redis-4.5.1.ebuild
diff --git a/dev-python/requests-cache/requests-cache-0.9.7.ebuild b/dev-python/requests-cache/requests-cache-0.9.7.ebuild
index 698cd213dcf6..358a9638f092 100644
--- a/dev-python/requests-cache/requests-cache-0.9.7.ebuild
+++ b/dev-python/requests-cache/requests-cache-0.9.7.ebuild
@@ -62,7 +62,7 @@ python_test() {
}
pkg_postinst() {
- optfeature "redis backend" "dev-python/redis-py"
+ optfeature "redis backend" "dev-python/redis"
optfeature "MongoDB backend" "dev-python/pymongo"
optfeature "JSON serialization" "dev-python/ujson"
diff --git a/dev-python/requests-cache/requests-cache-0.9.8.ebuild b/dev-python/requests-cache/requests-cache-0.9.8.ebuild
index 3623435e40dd..76068a967f47 100644
--- a/dev-python/requests-cache/requests-cache-0.9.8.ebuild
+++ b/dev-python/requests-cache/requests-cache-0.9.8.ebuild
@@ -62,7 +62,7 @@ python_test() {
}
pkg_postinst() {
- optfeature "redis backend" "dev-python/redis-py"
+ optfeature "redis backend" "dev-python/redis"
optfeature "MongoDB backend" "dev-python/pymongo"
optfeature "JSON serialization" "dev-python/ujson"
diff --git a/dev-python/rq/rq-1.11.1.ebuild b/dev-python/rq/rq-1.11.1.ebuild
index c7a3703127c6..2cb40564e537 100644
--- a/dev-python/rq/rq-1.11.1.ebuild
+++ b/dev-python/rq/rq-1.11.1.ebuild
@@ -24,7 +24,7 @@ KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
RDEPEND="
>=dev-python/click-5.0[${PYTHON_USEDEP}]
- >=dev-python/redis-py-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-3.5.0[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
diff --git a/dev-python/rq/rq-1.12.0.ebuild b/dev-python/rq/rq-1.12.0.ebuild
index b3eae1948c5a..7483126181b1 100644
--- a/dev-python/rq/rq-1.12.0.ebuild
+++ b/dev-python/rq/rq-1.12.0.ebuild
@@ -24,7 +24,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
RDEPEND="
>=dev-python/click-5.0[${PYTHON_USEDEP}]
- >=dev-python/redis-py-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-3.5.0[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
diff --git a/dev-python/spotipy/spotipy-2.22.1.ebuild b/dev-python/spotipy/spotipy-2.22.1.ebuild
index cee91b6335a1..a52000b0bcbc 100644
--- a/dev-python/spotipy/spotipy-2.22.1.ebuild
+++ b/dev-python/spotipy/spotipy-2.22.1.ebuild
@@ -25,7 +25,7 @@ SLOT="0"
IUSE="examples"
RDEPEND="
- dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/urllib3[${PYTHON_USEDEP}]