summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2016-04-06 15:20:51 +0200
committerTobias Klausmann <klausman@gentoo.org>2016-04-06 15:20:51 +0200
commit59f05a4e4e20537a3f522a5e64986a9abc862726 (patch)
tree5d6a6f7d5377391d8ab2d527dae38714a9aa5c6a /dev-python
parentx11-misc/sddm: amd64 stable wrt bug #577180 (diff)
downloadgentoo-59f05a4e4e20537a3f522a5e64986a9abc862726.tar.gz
gentoo-59f05a4e4e20537a3f522a5e64986a9abc862726.tar.bz2
gentoo-59f05a4e4e20537a3f522a5e64986a9abc862726.zip
dev-python/progressbar: Enable pypy3 support
Since all of progressbar's deps now support pypy3, we can enable it for progressbar itself, too. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/progressbar/progressbar-2.3-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/progressbar/progressbar-2.3-r2.ebuild b/dev-python/progressbar/progressbar-2.3-r2.ebuild
new file mode 100644
index 000000000000..f7983acb3b45
--- /dev/null
+++ b/dev-python/progressbar/progressbar-2.3-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Text progressbar library for python"
+HOMEPAGE="https://code.google.com/p/python-progressbar/ https://pypi.python.org/pypi/progressbar"
+SRC_URI="https://python-${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/progressbar-2.3-python3.3.patch" )