summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-11 04:57:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-11 05:05:58 +0200
commit4736287e145a99dece4128940a0fa7f26a982397 (patch)
treec5b7b7ebf42c97fcabd7b9961fcdacfa23514918 /dev-python
parentdev-python/cfn-lint: Bump to 1.16.1 (diff)
downloadgentoo-4736287e145a99dece4128940a0fa7f26a982397.tar.gz
gentoo-4736287e145a99dece4128940a0fa7f26a982397.tar.bz2
gentoo-4736287e145a99dece4128940a0fa7f26a982397.zip
dev-python/wsaccel: Bump to 0.6.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wsaccel/Manifest1
-rw-r--r--dev-python/wsaccel/wsaccel-0.6.7.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/wsaccel/Manifest b/dev-python/wsaccel/Manifest
index 814d6171a347..56a2396b61b0 100644
--- a/dev-python/wsaccel/Manifest
+++ b/dev-python/wsaccel/Manifest
@@ -1 +1,2 @@
DIST wsaccel-0.6.6.gh.tar.gz 9930 BLAKE2B f8d8c9ae0966374fbd965859150cca68b3fae6f39fdcfa744f98e7fade2a76946b57bea753c2dbb4051ef635e0dd0fbfd915c7f8bf4b9b5cd2b5b372694d632f SHA512 4a107db921f6f6549fb9f2f0b5c698331274171ef509136fc2d83cb6ca8bedbde32a14aaca4e38e16af3054337774dbd6aa7d8caee7866a51ded751d7d3764be
+DIST wsaccel-0.6.7.gh.tar.gz 10077 BLAKE2B efaaf3ab90acd963c630a808c15857ab75ab9de27fba5de2462800ad131a64bf153100348c872d327439355ad4328c111b425ee9166f2b2fcbc6e099d6cd9fc2 SHA512 fd3d2d6dc94f9922e05b4a957a02b9f765c9a0aa649859151f7e62a8dc4b382812b31ace42a27c1ef35904bc3c8155cba738322deeba834afd0a8049efec62a7
diff --git a/dev-python/wsaccel/wsaccel-0.6.7.ebuild b/dev-python/wsaccel/wsaccel-0.6.7.ebuild
new file mode 100644
index 000000000000..e4c09e9fd1a3
--- /dev/null
+++ b/dev-python/wsaccel/wsaccel-0.6.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Accelerator for ws4py, autobahn and tornado"
+HOMEPAGE="
+ https://github.com/methane/wsaccel/
+ https://pypi.org/project/wsaccel/
+"
+SRC_URI="
+ https://github.com/methane/wsaccel/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd tests || die
+ epytest
+}