summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-04 09:39:19 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-04 10:19:43 +0200
commit164001708efbc0dcbe19890c1d4a9cc6bb6af2c1 (patch)
tree2217251ced3d73177cfb54fb6492f3bd31a2b044 /dev-python
parentdev-python/google-api-python-client: Bump to 2.47.0 (diff)
downloadgentoo-164001708efbc0dcbe19890c1d4a9cc6bb6af2c1.tar.gz
gentoo-164001708efbc0dcbe19890c1d4a9cc6bb6af2c1.tar.bz2
gentoo-164001708efbc0dcbe19890c1d4a9cc6bb6af2c1.zip
dev-python/django-debug-toolbar: Bump to 3.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-debug-toolbar/Manifest1
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-3.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index 2aa96ac4a7de..2f0a94beea19 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,2 +1,3 @@
DIST django-debug-toolbar-3.2.4.tar.gz 255283 BLAKE2B 8be7f569c7f1eab06c4a60fca19bce6c348594406cdfe6de7e6be50849272714e9f3b51db4803e7cd58e97fe44a7422b07b05b2208f4447a4d69e0b77c856cb4 SHA512 19d3ba91b8738ade108f7eaded2859ad3e4bcae7cd0115e2cf63698d1fef01773f09a05f6bc0af53f9c3d4a2a288635a5cb2d215a2eb9f8acd6c65175a1ccaef
DIST django-debug-toolbar-3.3.tar.gz 259488 BLAKE2B ea69c02f95bc82690fbef6d826c0e48229e6ce27ec55f26cf9991736789c8e8bd0f4b180fbc1a36a3bc3f890798925e5ff2ef5bd09e6a743adb0770d53cf1e9b SHA512 e9f919f74f58345fec402d9595e739e3619cae90d03f8c5efe7b4c5c191b339e594efd4b9823b3952a3f50d3c5bb7257a0e9eb6a7e60059433a61a8f684a1b21
+DIST django-debug-toolbar-3.4.tar.gz 259964 BLAKE2B 3cd33e0cb7db9afca41961df6b3c7623c1ab698e5751a55a8e12b5339d95af9e44892465a81cdfb822054899a11430d371081243a48c09caf47e764c31243712 SHA512 c6ecc0e1304cc0f3db60670518dc9b0631606a786a2ea71db940dfc641865214c9d2b9a8f302232a4664663f1745996351f3ac9b3b5928a6323779bdb3dcc11e
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-3.4.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-3.4.ebuild
new file mode 100644
index 000000000000..1d724aaa1b7b
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="
+ https://pypi.org/project/django-debug-toolbar/
+ https://github.com/jazzband/django-debug-toolbar/
+"
+SRC_URI="
+ https://github.com/jazzband/django-debug-toolbar/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.3[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ emake TEST_ARGS='-v 2 tests' test
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}