summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-11-13 12:45:02 +0200
committerMichał Górny <mgorny@gentoo.org>2019-11-30 09:28:05 +0100
commitff660eeeb187ec597f3009c5c0fc8b10f225fbe8 (patch)
tree153678607d5c586a20002ca733ae5b55349c0c27 /dev-python/zope-schema
parentdev-python/zope-i18nmessageid: bump v5.0.0, EAPI=7 (diff)
downloadgentoo-ff660eeeb187ec597f3009c5c0fc8b10f225fbe8.tar.gz
gentoo-ff660eeeb187ec597f3009c5c0fc8b10f225fbe8.tar.bz2
gentoo-ff660eeeb187ec597f3009c5c0fc8b10f225fbe8.zip
dev-python/zope-schema: bump v4.9.3, EAPI=7
add python 3_7, python3_8 add tests use distutils_enable_tests for tests Closes: https://bugs.gentoo.org/691534 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zope-schema')
-rw-r--r--dev-python/zope-schema/Manifest1
-rw-r--r--dev-python/zope-schema/zope-schema-4.9.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/zope-schema/Manifest b/dev-python/zope-schema/Manifest
index adb5eda16f94..91b39ce7c473 100644
--- a/dev-python/zope-schema/Manifest
+++ b/dev-python/zope-schema/Manifest
@@ -1 +1,2 @@
DIST zope.schema-4.5.0.tar.gz 76962 BLAKE2B 2ce5ddc674381bc5270865e141196e3edd10a6ad8f96a191d9bc603c99305e186f3cda9f92cd565c1f4956b4c68f2ab083187a85dabc6dae4a3c2e25cc6dbc73 SHA512 77f3f65a3d0b52f770a381d869b254f5457223b5fdda4b031e9531c57664dd151b4dc293d3cdc6dff5cad58d656d951e0d964fad9521100b7e007b4c15e52740
+DIST zope.schema-4.9.3.tar.gz 98217 BLAKE2B 9b3288bf8b07174fbbd919398cc441f5585671e312651f9cbcbbab9f885af67f5f8e954d70bd4787e8f17bd465f8152c685b894188d05a0663344fb8b3c70569 SHA512 63cdf431ba2aa79eb5771f99cf0a60932182edae00a63873f96cc02c70f826d23c72ecabd736d0f6439d63af900b4ee2c05246eabe0b1689b01bc15a09648504
diff --git a/dev-python/zope-schema/zope-schema-4.9.3.ebuild b/dev-python/zope-schema/zope-schema-4.9.3.ebuild
new file mode 100644
index 000000000000..2350510ec5a3
--- /dev/null
+++ b/dev-python/zope-schema/zope-schema-4.9.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope schema Architecture"
+HOMEPAGE="https://github.com/zopefoundation/zope.schema http://docs.zope.org/zope.schema/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/zope-event[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ dev-python/zope-testrunner[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}