summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-09 06:16:52 +0100
committerSam James <sam@gentoo.org>2022-06-09 06:17:37 +0100
commit66e8373eefd379b9e2424b696abe7094e4e292eb (patch)
treed3b31337e7330a4d5771a4dc9330698254090d71 /dev-python/yara-python
parentdev-ruby/warden: enable ruby31 (diff)
downloadgentoo-66e8373eefd379b9e2424b696abe7094e4e292eb.tar.gz
gentoo-66e8373eefd379b9e2424b696abe7094e4e292eb.tar.bz2
gentoo-66e8373eefd379b9e2424b696abe7094e4e292eb.zip
dev-python/yara-python: fix python_compile
We shouldn't be using foreach_impl w/ distutils-r1 (at least when D_U_PEP517!=no) Closes: https://bugs.gentoo.org/850619 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/yara-python')
-rw-r--r--dev-python/yara-python/yara-python-4.2.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/yara-python/yara-python-4.2.0-r1.ebuild b/dev-python/yara-python/yara-python-4.2.0-r1.ebuild
new file mode 100644
index 000000000000..fa16ee3db1f1
--- /dev/null
+++ b/dev-python/yara-python/yara-python-4.2.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface for a malware identification and classification tool"
+HOMEPAGE="https://github.com/VirusTotal/yara-python"
+SRC_URI="https://github.com/virustotal/yara-python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ =app-forensics/yara-$(ver_cut 1-2)*"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+python_compile() {
+ distutils-r1_python_compile --dynamic-linking
+}
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}