summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-27 13:55:43 -0500
committerMichał Górny <mgorny@gentoo.org>2018-04-29 12:29:23 +0200
commit05247111fba146d1ca3f5c1bf460d3cd0b0eca8d (patch)
tree660bfb46623204f046209f4e5b49db88cab05550 /dev-python/ws4py
parentdev-python/flask: git-2->git-r3, unify ebuilds (diff)
downloadgentoo-05247111fba146d1ca3f5c1bf460d3cd0b0eca8d.tar.gz
gentoo-05247111fba146d1ca3f5c1bf460d3cd0b0eca8d.tar.bz2
gentoo-05247111fba146d1ca3f5c1bf460d3cd0b0eca8d.zip
dev-python/ws4py: git-2->git-r3
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-python/ws4py')
-rw-r--r--dev-python/ws4py/ws4py-0.3.4-r1.ebuild10
-rw-r--r--dev-python/ws4py/ws4py-0.3.4.ebuild10
-rw-r--r--dev-python/ws4py/ws4py-0.5.1.ebuild4
-rw-r--r--dev-python/ws4py/ws4py-9999.ebuild2
4 files changed, 13 insertions, 13 deletions
diff --git a/dev-python/ws4py/ws4py-0.3.4-r1.ebuild b/dev-python/ws4py/ws4py-0.3.4-r1.ebuild
index 6ab67dfda7d9..ee738e5a2731 100644
--- a/dev-python/ws4py/ws4py-0.3.4-r1.ebuild
+++ b/dev-python/ws4py/ws4py-0.3.4-r1.ebuild
@@ -6,17 +6,17 @@
# Same for www-servers/tornado and USE=client ... so why not???
# pypy is viable but better with a cutdown set of deps
-EAPI="5"
+EAPI=5
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
PYTHON_REQ_USE="threads?"
inherit distutils-r1
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
- inherit git-2
+ inherit git-r3
else
inherit vcs-snapshot
- SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}.tar.gz"
+ SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/v${PV} -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~x86"
fi
@@ -40,7 +40,7 @@ DEPEND="test? (
)"
PATCHES=(
- "${FILESDIR}"/${P}-tests.patch
+ "${FILESDIR}"/${PN}-0.3.4-tests.patch
)
python_test() {
diff --git a/dev-python/ws4py/ws4py-0.3.4.ebuild b/dev-python/ws4py/ws4py-0.3.4.ebuild
index a7084914ad69..72726e9eda13 100644
--- a/dev-python/ws4py/ws4py-0.3.4.ebuild
+++ b/dev-python/ws4py/ws4py-0.3.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# We could depend on dev-python/cherrypy when USE=server, but
@@ -6,17 +6,17 @@
# Same for www-servers/tornado and USE=client ... so why not???
# pypy is viable but better with a cutdown set of deps
-EAPI="5"
+EAPI=5
PYTHON_COMPAT=( python{2_7,3_4,3_5} )
PYTHON_REQ_USE="threads?"
inherit distutils-r1
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
- inherit git-2
+ inherit git-r3
else
inherit vcs-snapshot
- SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}.tar.gz"
+ SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/v${PV} -> ${P}.tar.gz"
KEYWORDS="amd64 arm x86"
fi
diff --git a/dev-python/ws4py/ws4py-0.5.1.ebuild b/dev-python/ws4py/ws4py-0.5.1.ebuild
index c1c647c9a5e3..b8797e5d4151 100644
--- a/dev-python/ws4py/ws4py-0.5.1.ebuild
+++ b/dev-python/ws4py/ws4py-0.5.1.ebuild
@@ -6,14 +6,14 @@
# Same for www-servers/tornado and USE=client ... so why not???
# pypy is viable but better with a cutdown set of deps
-EAPI="6"
+EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
PYTHON_REQ_USE="threads?"
inherit distutils-r1
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
- inherit git-3
+ inherit git-r3
else
inherit vcs-snapshot
SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/${PV}.tar.gz -> ${P}.tar.gz"
diff --git a/dev-python/ws4py/ws4py-9999.ebuild b/dev-python/ws4py/ws4py-9999.ebuild
index 74386cac1ba9..b8797e5d4151 100644
--- a/dev-python/ws4py/ws4py-9999.ebuild
+++ b/dev-python/ws4py/ws4py-9999.ebuild
@@ -6,7 +6,7 @@
# Same for www-servers/tornado and USE=client ... so why not???
# pypy is viable but better with a cutdown set of deps
-EAPI="6"
+EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
PYTHON_REQ_USE="threads?"