summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-15 21:07:02 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-15 21:15:23 +0200
commitf0eb0af7ebefb64aa0cc52f24deadd0180194597 (patch)
treea2a6657df1c39edcb228972360f72b97882ff18e /dev-python/whoosh
parentdev-python/x-wr-timezone: Enable py3.13 (diff)
downloadgentoo-f0eb0af7ebefb64aa0cc52f24deadd0180194597.tar.gz
gentoo-f0eb0af7ebefb64aa0cc52f24deadd0180194597.tar.bz2
gentoo-f0eb0af7ebefb64aa0cc52f24deadd0180194597.zip
dev-python/whoosh: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/whoosh')
-rw-r--r--dev-python/whoosh/whoosh-2.7.4-r2.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/whoosh/whoosh-2.7.4-r2.ebuild b/dev-python/whoosh/whoosh-2.7.4-r2.ebuild
index 8b2f267ea928..4e4aa79962dc 100644
--- a/dev-python/whoosh/whoosh-2.7.4-r2.ebuild
+++ b/dev-python/whoosh/whoosh-2.7.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYPI_PN=${PN^}
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
@@ -26,13 +26,16 @@ PATCHES=(
distutils_enable_sphinx docs/source
distutils_enable_tests pytest
+EPYTEST_DESELECT=(
+ # TODO
+ tests/test_automata.py::test_minimize_dfa
+)
+
python_prepare_all() {
# (backport from upstream)
sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die
# fix old section name
sed -i -e 's@\[pytest\]@[tool:pytest]@' setup.cfg || die
- # TODO: broken?
- sed -i -e 's:test_minimize_dfa:_&:' tests/test_automata.py || die
distutils-r1_python_prepare_all
}