summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-30 18:43:23 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-30 21:12:13 -0500
commitb54a183dd82914e18bd3ddaae8605e029c4ad14d (patch)
tree41edd0e616280b03be74d6e95c057720ae2678d9 /dev-python/websockify
parentmedia-libs/webrtc-audio-processing: x86 stable, bug 587010 (diff)
downloadgentoo-b54a183dd82914e18bd3ddaae8605e029c4ad14d.tar.gz
gentoo-b54a183dd82914e18bd3ddaae8605e029c4ad14d.tar.bz2
gentoo-b54a183dd82914e18bd3ddaae8605e029c4ad14d.zip
openstack p2, newton is done, will add heat later
Diffstat (limited to 'dev-python/websockify')
-rw-r--r--dev-python/websockify/Manifest1
-rw-r--r--dev-python/websockify/websockify-0.8.0.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/websockify/Manifest b/dev-python/websockify/Manifest
index eecbcdb275db..b9f0716bccd9 100644
--- a/dev-python/websockify/Manifest
+++ b/dev-python/websockify/Manifest
@@ -1 +1,2 @@
DIST websockify-0.7.0.zip 316823 SHA256 a1d1f2a188f34622ae6349c2cd19067a9a6f89ff3d35e249559ffa9c75a9d05b SHA512 642a65239fbaa409127e18f637cbcc815af0e34b89573517c5fef0b2c5af71442ab2ff563ff0cc7fcfa41c87711b9d478c708ca4424bb08d288537f0f1b4b4ef WHIRLPOOL eb331874712f2ac98eff4749b7b2c76ee5976a5488b7db49006624a88a019a7813da2ccd45b68bc4930cb43e9b2c69b2a4cbd6fd3ab2ae02c2e9ea3dc131f4cd
+DIST websockify-0.8.0.zip 319105 SHA256 fc0cadd72c22a245ddd0d418e68cab07c4355754a070e39371c86ad92980ae0f SHA512 625cecbf37149c82edd2ebb9cd1f1a20a35415f7c7696ebe88b2e86563a170573959f9ede2c7a1db82ace9edddfb9d2da6e2e20d29fd916ae238235880d9a943 WHIRLPOOL 39e19a253b518b4cf53cce27a293317e47eb4159fd0bac21324649dfc872bfa3372a1043b4d4f976a72595cf5be84a7f88307b123af6938130339cdc99b76d56
diff --git a/dev-python/websockify/websockify-0.8.0.ebuild b/dev-python/websockify/websockify-0.8.0.ebuild
new file mode 100644
index 000000000000..bba0c42100d4
--- /dev/null
+++ b/dev-python/websockify/websockify-0.8.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+SRC_URI="https://github.com/kanaka/${PN}/archive/v${PV}.zip -> ${P}.zip"
+DESCRIPTION="WebSockets support for any application/server"
+HOMEPAGE="https://github.com/kanaka/websockify"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"