summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-03-23 08:04:40 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2020-03-23 08:04:57 -0400
commitb7173ba5efe59a773db32f18304795ad97c32a7c (patch)
treec214683ea7af549ddedb8c1ed0c871b2ad1c0cbf /dev-python/weasyprint
parentnet-mail/mailutils: bump to 3.9 (diff)
downloadgentoo-b7173ba5efe59a773db32f18304795ad97c32a7c.tar.gz
gentoo-b7173ba5efe59a773db32f18304795ad97c32a7c.tar.bz2
gentoo-b7173ba5efe59a773db32f18304795ad97c32a7c.zip
dev-python/weasyprint: Bump to 51, Add Py 3.{7,8}
Add support for Python 3.7 and 3.8. Bump to 51. Refresh dependencies. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/files/weasyprint-51-skip-useless-deps.patch30
-rw-r--r--dev-python/weasyprint/weasyprint-51.ebuild52
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index 83651390b2b5..60185928ff33 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1,2 +1,3 @@
DIST WeasyPrint-0.41.tar.gz 393866 BLAKE2B 895624ee547a9ed91157db6a7a72890a56f270d2ea00a508c42899e42922e51867782b1dff3ab55f98df0a130b727a7db13aaf3553a90c4405b75b6813c95ab9 SHA512 44b2d9e0a186c5767cd01d6e66495241d088908467e0fa28cee114a9c480bfcb4ef393236e9304653603f3917c73c452c05a38286932e0a271946860120d9a1f
DIST WeasyPrint-43.tar.gz 315365 BLAKE2B af643f6a6d09d09d89802dd3823e43e9f05873738b14e4f853a324850ffc12902cb791c3f187f6b550dded40669d376cf3d2e4d7d83e9747e87795a4d57e9014 SHA512 fc4c4decb298d4f9caf244433566c9b675b23db2508093d8c43c6e361119c5fe8298213075f550bebc72fe4156cfc516f04c8d7a2c6215fcd5add14360821f40
+DIST WeasyPrint-51.tar.gz 308411 BLAKE2B f88f9e1abc09986d51d92d8a153c71242cadc8ce6b8ac99a08d86746677d40a86affe3c56dd3e3e6a0eb2fc915f77036271f049f6ccc644d508be51d01d97b7c SHA512 631038bece7ac0c15c6a668a7d06137e4bccc049eb80484a153ca9c4a996256de8647428b21ed1d0c1607af3893c747a1956a3d3f012b30105ba4f8613a96fcd
diff --git a/dev-python/weasyprint/files/weasyprint-51-skip-useless-deps.patch b/dev-python/weasyprint/files/weasyprint-51-skip-useless-deps.patch
new file mode 100644
index 000000000000..862f11dc0a04
--- /dev/null
+++ b/dev-python/weasyprint/files/weasyprint-51-skip-useless-deps.patch
@@ -0,0 +1,30 @@
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -40,7 +40,6 @@
+ [options]
+ packages = find:
+ zip_safe = false
+-setup_requires = pytest-runner
+ install_requires =
+ setuptools>=39.2.0
+ cffi>=0.6
+@@ -50,11 +49,6 @@
+ cssselect2>=0.1
+ CairoSVG>=2.4.0
+ Pyphen>=0.9.1
+-tests_require =
+- pytest-runner
+- pytest-cov
+- pytest-flake8
+- pytest-isort
+ python_requires = >= 3.5
+
+ [options.entry_points]
+@@ -86,7 +80,6 @@
+ test = pytest
+
+ [tool:pytest]
+-addopts = --flake8 --isort
+ norecursedirs = build dist .cache .eggs .git
+
+ [coverage:run]
diff --git a/dev-python/weasyprint/weasyprint-51.ebuild b/dev-python/weasyprint/weasyprint-51.ebuild
new file mode 100644
index 000000000000..fdcc64deeca7
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-51.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+MY_PN="WeasyPrint"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://weasyprint.org https://github.com/Kozea/WeasyPrint"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jpeg test tiff"
+RESTRICT="!test? ( test )"
+
+# Note: specific subslot of pango since it inlines some of pango headers.
+# >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/cairocffi-0.9[${PYTHON_USEDEP}]
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-0.999999999[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ >=media-gfx/cairosvg-2.4.0[${PYTHON_USEDEP}]
+ >=x11-libs/cairo-1.15.4
+ x11-libs/gdk-pixbuf[jpeg?,tiff?]
+ x11-libs/pango:0/0
+"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ media-fonts/ahem
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-51-skip-useless-deps.patch" )
+# "${FILESDIR}/${PN}-43-skip-failing-test.patch"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ pytest -vv || die "testsuite failed under ${EPYTHON}"
+}