summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <nils.freydank@posteo.de>2020-08-15 14:57:00 +0200
committerAndrey Utkin <andrey_utkin@gentoo.org>2020-08-30 14:47:53 +0100
commite5c49e2699aa52e7b89956a63f970828a8f0e370 (patch)
treeed786bdc35459f6477b899bf2235ee723be2933e /dev-python/vobject
parentapp-misc/khard: Add myself as proxied maintainer (diff)
downloadgentoo-e5c49e2699aa52e7b89956a63f970828a8f0e370.tar.gz
gentoo-e5c49e2699aa52e7b89956a63f970828a8f0e370.tar.bz2
gentoo-e5c49e2699aa52e7b89956a63f970828a8f0e370.zip
dev-python/vobject: Add support for python3_9
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'dev-python/vobject')
-rw-r--r--dev-python/vobject/vobject-0.9.6.1-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/vobject/vobject-0.9.6.1-r2.ebuild b/dev-python/vobject/vobject-0.9.6.1-r2.ebuild
new file mode 100644
index 000000000000..ce291e2f41a7
--- /dev/null
+++ b/dev-python/vobject/vobject-0.9.6.1-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python package for parsing and generating vCard and vCalendar files"
+HOMEPAGE="https://eventable.github.io/vobject/
+ https://pypi.org/project/vobject/
+ https://github.com/eventable/vobject"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+DOCS=( ACKNOWLEDGEMENTS.txt README.md )
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Testing failed under ${EPYTHON}"
+}