summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/visual
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/visual')
-rw-r--r--dev-python/visual/Manifest1
-rw-r--r--dev-python/visual/files/visual-5.74-boost-1.50.patch28
-rw-r--r--dev-python/visual/metadata.xml5
-rw-r--r--dev-python/visual/visual-5.74.ebuild85
4 files changed, 119 insertions, 0 deletions
diff --git a/dev-python/visual/Manifest b/dev-python/visual/Manifest
new file mode 100644
index 000000000000..97868d71e869
--- /dev/null
+++ b/dev-python/visual/Manifest
@@ -0,0 +1 @@
+DIST visual-5.74_release.tar.bz2 5736404 SHA256 1e480d3fd82e8172021ae0e22e8e2859f44bec9297e12ebf672270fd8e7d7099 SHA512 eff43bae66d4ca6a1b540e729b5f03e7310db8d4c49ba7a1ac271afa62688d9024f4f00b7678669433ca3f0f6e13e6c0c3de90a4a845ae5eeaa70b536a6e1193 WHIRLPOOL d0c35354e8fcaf591870dce867e60a9b54a9eb31acdd6eb05331566c031bf0a7da794e7f9dc8e013eff10583eadccefda08ef79443761129d9ca56f05626acd8
diff --git a/dev-python/visual/files/visual-5.74-boost-1.50.patch b/dev-python/visual/files/visual-5.74-boost-1.50.patch
new file mode 100644
index 000000000000..a66ded258987
--- /dev/null
+++ b/dev-python/visual/files/visual-5.74-boost-1.50.patch
@@ -0,0 +1,28 @@
+https://github.com/vpython/visual/issues/3
+
+--- dependencies/threadpool/include/threadpool/task_adaptors.hpp
++++ dependencies/threadpool/include/threadpool/task_adaptors.hpp
+@@ -135,7 +135,11 @@
+ if(m_break_s > 0 || m_break_ns > 0)
+ { // Sleep some time before first execution
+ xtime xt;
++#if BOOST_VERSION >= 105000
++ xtime_get(&xt, TIME_UTC_);
++#else
+ xtime_get(&xt, TIME_UTC);
++#endif
+ xt.nsec += m_break_ns;
+ xt.sec += m_break_s;
+ thread::sleep(xt);
+@@ -146,7 +150,11 @@
+ if(m_break_s > 0 || m_break_ns > 0)
+ {
+ xtime xt;
++#if BOOST_VERSION >= 105000
++ xtime_get(&xt, TIME_UTC_);
++#else
+ xtime_get(&xt, TIME_UTC);
++#endif
+ xt.nsec += m_break_ns;
+ xt.sec += m_break_s;
+ thread::sleep(xt);
diff --git a/dev-python/visual/metadata.xml b/dev-python/visual/metadata.xml
new file mode 100644
index 000000000000..ee7e8b2450a8
--- /dev/null
+++ b/dev-python/visual/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/visual/visual-5.74.ebuild b/dev-python/visual/visual-5.74.ebuild
new file mode 100644
index 000000000000..5ac636da6567
--- /dev/null
+++ b/dev-python/visual/visual-5.74.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.* *-jython 2.7-pypy-*"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit eutils flag-o-matic multilib python versionator
+
+MY_P="${PN}-$(delete_version_separator 2)_release"
+
+DESCRIPTION="Real-time 3D graphics library for Python"
+HOMEPAGE="http://www.vpython.org/"
+SRC_URI="http://www.vpython.org/contents/download/${MY_P}.tar.bz2"
+
+LICENSE="HPND Boost-1.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc examples"
+
+RDEPEND=">=dev-cpp/gtkglextmm-1.2
+ dev-cpp/libglademm
+ >=dev-libs/boost-1.48[python]
+ dev-python/numpy
+ dev-python/polygon:2
+ dev-python/ttfquery"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Verbose build.
+ sed -i \
+ -e 's/2\?>>[[:space:]]*\$(LOGFILE).*//' \
+ src/Makefile.in || die
+
+ epatch "${FILESDIR}/${P}-boost-1.50.patch"
+
+ python_clean_py-compile_files
+ python_src_prepare
+
+ preparation() {
+ sed -i \
+ -e "s/-lboost_python/-lboost_python-${PYTHON_ABI}/" \
+ -e "s/libboost_python/libboost_python-${PYTHON_ABI}/" \
+ src/Makefile.in src/gtk2/makefile
+ }
+ python_execute_function -s preparation
+}
+
+src_configure() {
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.48")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="${EPREFIX}/usr/include/boost-${BOOST_VER}"
+ BOOST_LIB="${EPREFIX}/usr/$(get_libdir)/boost-${BOOST_VER}"
+
+ # Specify the include and lib directory for Boost.
+ append-cxxflags -I${BOOST_INC}
+ append-ldflags -L${BOOST_LIB}
+
+ python_src_configure \
+ --with-example-dir="${EPREFIX}/usr/share/doc/${PF}/examples" \
+ --with-html-dir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ $(use_enable doc docs) \
+ $(use_enable examples)
+}
+
+src_install() {
+ python_src_install
+ python_clean_installation_image
+
+ dodoc authors.txt HACKING.txt NEWS.txt
+}
+
+pkg_postinst() {
+ python_mod_optimize vis visual
+}
+
+pkg_postrm() {
+ python_mod_cleanup vis visual
+}