summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-01-20 18:32:07 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-20 19:55:26 +0200
commitb04a6b8c718e96fb5eeb045c69eb37baf75f0c12 (patch)
treef95d0031d04153984d1a2e6f1625ef1e03f254d8 /dev-python/vecrec
parentdev-python/flask-nav: enable py3.11 (diff)
downloadgentoo-b04a6b8c718e96fb5eeb045c69eb37baf75f0c12.tar.gz
gentoo-b04a6b8c718e96fb5eeb045c69eb37baf75f0c12.tar.bz2
gentoo-b04a6b8c718e96fb5eeb045c69eb37baf75f0c12.zip
dev-python/vecrec: PEP517 (using flit), enable py3.11
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/vecrec')
-rw-r--r--dev-python/vecrec/vecrec-0.3.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/vecrec/vecrec-0.3.1-r1.ebuild b/dev-python/vecrec/vecrec-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..184ce40f2281
--- /dev/null
+++ b/dev-python/vecrec/vecrec-0.3.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="2D vector and rectangle classes"
+HOMEPAGE="https://github.com/kxgames/vecrec
+ https://pypi.org/project/vecrec/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="dev-python/autoprop[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/addopts/d' -i tests/pytest.ini || die
+ sed -e '/build-backend/s/flit.buildapi/flit_core.buildapi/' \
+ -e '/requires/s/flit/flit_core/' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests
+}