summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-16 19:56:34 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-16 19:56:34 +0300
commit5cd9ca34ac7cf6ee0e94d827f8a9172855521eb7 (patch)
treec5e2612f1bc448e897260a63d4fdc47182f77692 /dev-python/vdf
parentdev-python/vobject: enable py3.11 (diff)
downloadgentoo-5cd9ca34ac7cf6ee0e94d827f8a9172855521eb7.tar.gz
gentoo-5cd9ca34ac7cf6ee0e94d827f8a9172855521eb7.tar.bz2
gentoo-5cd9ca34ac7cf6ee0e94d827f8a9172855521eb7.zip
dev-python/vdf: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/vdf')
-rw-r--r--dev-python/vdf/vdf-3.4-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/vdf/vdf-3.4-r1.ebuild b/dev-python/vdf/vdf-3.4-r1.ebuild
new file mode 100644
index 000000000000..f8164cd225f5
--- /dev/null
+++ b/dev-python/vdf/vdf-3.4-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for (de)serialization to and from VDF, Valve's key-value text format"
+HOMEPAGE="https://github.com/ValvePython/vdf"
+SRC_URI="https://codeload.github.com/ValvePython/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest