summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-16 21:07:17 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-16 21:07:40 +0200
commitc20b5bfa7bb575aab0757ea0959002d5ab17b69a (patch)
tree43587e6863562d1604898277a6581dd76d7bc296 /dev-python/urllib3
parentdev-python/identify: add 2.4.12 (diff)
downloadgentoo-c20b5bfa7bb575aab0757ea0959002d5ab17b69a.tar.gz
gentoo-c20b5bfa7bb575aab0757ea0959002d5ab17b69a.tar.bz2
gentoo-c20b5bfa7bb575aab0757ea0959002d5ab17b69a.zip
dev-python/urllib3: add 1.26.9
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest1
-rw-r--r--dev-python/urllib3/urllib3-1.26.9.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index a1e8cdf4bc13..e5829cd73eb0 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1 +1,2 @@
DIST urllib3-1.26.8.tar.gz 294280 BLAKE2B 401801b16c0c5152cabdfe3317cc53bc79a5aec103cc53a22189dcefcf0d022a05f6afac0bd99274a2fe48b6e86da8eb544b78e4c3a1534f000a9756ff15ccd9 SHA512 bcb56faa5dbe6019f70b63c076e118ec5f89e2d0c25f0e415d9db079532c98ced7e636cec5bf26210d4b0a08bb7b5b7a33a5c8648ccdaad129eea3a212a53bc5
+DIST urllib3-1.26.9.tar.gz 295258 BLAKE2B 1c6b51e4243c18c25bcb53158e645ea71fe33e0d09ca029256bcbe05bf178ba600dd8911c71730bdefc3cf9f65cdfd5740f579d17d293f9ac7c5d3cbff478b6f SHA512 ac384291b02516dee781c98182625356ac7bc03972612577de5286e159cf161b541cc610b103e0eec1c9f40503049b41e972a9e0998fcd834efe2f40af0e7394
diff --git a/dev-python/urllib3/urllib3-1.26.9.ebuild b/dev-python/urllib3/urllib3-1.26.9.ebuild
new file mode 100644
index 000000000000..d1b0d817f2ef
--- /dev/null
+++ b/dev-python/urllib3/urllib3-1.26.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
+HOMEPAGE="https://github.com/urllib3/urllib3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="brotli test"
+RESTRICT="!test? ( test )"
+
+# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
+# dependencies. Do not add them to RDEPEND. They should be unnecessary with
+# modern versions of python (>= 3.2).
+RDEPEND="
+ >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
+ <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
+ brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep "
+ ${RDEPEND}
+ dev-python/brotlicffi[\${PYTHON_USEDEP}]
+ dev-python/mock[\${PYTHON_USEDEP}]
+ dev-python/pytest[\${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
+ " python3_{8..10})
+ )
+"
+
+python_test() {
+ local -x CI=1
+ # FIXME: get tornado ported
+ # please keep in sync with BDEPEND!
+ if ! has "${EPYTHON}" python3.{8..10}; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local EPYTEST_DESELECT=(
+ # TODO?
+ test/contrib/test_pyopenssl.py::TestHTTPS_TLSv1_3::test_verified
+ test/with_dummyserver/test_socketlevel.py::TestSocketClosing::test_timeout_errors_cause_retries
+ test/with_dummyserver/test_proxy_poolmanager.py::TestHTTPProxyManager::test_proxy_verified_warning
+ )
+
+ epytest
+}