summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-28 06:05:55 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-28 06:06:00 +0100
commitdd402bd19f9ec625813c157b8588bde5cf8f85db (patch)
treee283cb39bf9f3f3212875b822f3b1a3ceb327fad /dev-python/typeguard
parentdev-python/python-multipart: Bump to 0.0.16 (diff)
downloadgentoo-dd402bd19f9ec625813c157b8588bde5cf8f85db.tar.gz
gentoo-dd402bd19f9ec625813c157b8588bde5cf8f85db.tar.bz2
gentoo-dd402bd19f9ec625813c157b8588bde5cf8f85db.zip
dev-python/typeguard: Bump to 4.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typeguard')
-rw-r--r--dev-python/typeguard/Manifest1
-rw-r--r--dev-python/typeguard/typeguard-4.4.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/typeguard/Manifest b/dev-python/typeguard/Manifest
index 6fd58940634d..6cdb9f508522 100644
--- a/dev-python/typeguard/Manifest
+++ b/dev-python/typeguard/Manifest
@@ -1 +1,2 @@
DIST typeguard-4.3.0.tar.gz 73374 BLAKE2B 0a7cd0dfa2c3caa19160cd66fffeeafe21cb1d195271b82e67d26fa471615768c48f8dd7d92a004db187b9b231f1bce12f1054d98f4157b784854dbb32b18320 SHA512 ce085f0655beede2d3e1178c64cea0a6fbebe9e7eeece3f9ff656233d74d3d9be5c4119aaecdc0541e9adf9c6f1458b06e6c2056b8e5394ded3f7ae4101e9e11
+DIST typeguard-4.4.0.tar.gz 74399 BLAKE2B 2f4131e3ebf632660d2aa8838c729049b5a2e0864a2e18527a9a14527497341425507cb152fa48f507eb698f54b13f2a25caa173017619d5e6456ea582fd6433 SHA512 7c15cc724b8e4b0a5b777a14727a45cb0c039be18ade1ba6d8b00cfaaa3c2c7fc0c98320a53e172d07ad069f10b995384894e262a5bd14c00d6a04a7595e26aa
diff --git a/dev-python/typeguard/typeguard-4.4.0.ebuild b/dev-python/typeguard/typeguard-4.4.0.ebuild
new file mode 100644
index 000000000000..2fb152939008
--- /dev/null
+++ b/dev-python/typeguard/typeguard-4.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Run-time type checker for Python"
+HOMEPAGE="
+ https://pypi.org/project/typeguard/
+ https://github.com/agronholm/typeguard/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/typing-extensions-4.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # mypy changes results from version to version
+ # (we can't use EPYTEST_IGNORE because pytest_ignore_collect breaks it)
+ rm -rf tests/mypy || die
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # the XFAIL test pass due to some package being installed
+ epytest -o xfail_strict=False -p typeguard
+}