summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-09-08 09:24:18 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-09-08 09:24:38 +0300
commit598596b8e47171ca987beb8fbc28156d831a2173 (patch)
tree0215e6bb30a95a95200c0d170d053b23d6f1f0a3 /dev-python/texttable
parentdev-libs/check: restrict tests on ppc systems (diff)
downloadgentoo-598596b8e47171ca987beb8fbc28156d831a2173.tar.gz
gentoo-598596b8e47171ca987beb8fbc28156d831a2173.tar.bz2
gentoo-598596b8e47171ca987beb8fbc28156d831a2173.zip
dev-python/texttable: bump to 1.6.3
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/texttable')
-rw-r--r--dev-python/texttable/Manifest1
-rw-r--r--dev-python/texttable/texttable-1.6.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/texttable/Manifest b/dev-python/texttable/Manifest
index 41708b83179f..a5a265e7bee4 100644
--- a/dev-python/texttable/Manifest
+++ b/dev-python/texttable/Manifest
@@ -1 +1,2 @@
DIST texttable-1.6.2.tar.gz 11450 BLAKE2B 8090914b20a93283ea3d533a8120d4d2c5f058a0e79550b29d4b9fa740db5e309d84a7983fb6665149e3624ba7039b67ff6a553b180b915a348e5b53e793d5cd SHA512 e59275c64813bd00fa5172c43491820122b6045e1a416c917576cbf595c1ec24d146e571708379f4b32775bda904f16ced0e9e15ab7b2dde78a214f26a1c4de6
+DIST texttable-1.6.3.tar.gz 11574 BLAKE2B aebb306acb89f62963e9473ab6e22291a1ec93993a0106ddd2943f656737cb0960a10e680a69b6577ebb8ac0af3c6ecdfd8c58647a6ce37d9a6531e41f61f480 SHA512 89a26ef7d9947ec4edfc5791c91f2ac327c79bbc5aa0e0f89c0a63dbd80bc420027af073da935254faa143b9e8bef85a7bb352791b45b0cd60c7bcf569869f2d
diff --git a/dev-python/texttable/texttable-1.6.3.ebuild b/dev-python/texttable/texttable-1.6.3.ebuild
new file mode 100644
index 000000000000..16349f82863d
--- /dev/null
+++ b/dev-python/texttable/texttable-1.6.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Module for creating simple ASCII tables"
+HOMEPAGE="https://github.com/foutaise/texttable https://pypi.org/project/texttable/"
+SRC_URI="https://github.com/foutaise/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv tests.py || die
+}
+
+pkg_postinst() {
+ elog "Optional features: "
+ optfeature "better wrapping of CJK text" dev-python/cjkwrap
+}