summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-07-14 19:59:05 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-07-14 19:59:19 +0300
commitdad191a87128353c343f330b7843558e9faaa29b (patch)
tree42d74ec8743eca2af123e1143be6f27fb9b5c52a /dev-python/sybil
parentsys-libs/pam: Stabilize 1.5.3 ppc, #909813 (diff)
downloadgentoo-dad191a87128353c343f330b7843558e9faaa29b.tar.gz
gentoo-dad191a87128353c343f330b7843558e9faaa29b.tar.bz2
gentoo-dad191a87128353c343f330b7843558e9faaa29b.zip
dev-python/sybil: add 5.0.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-5.0.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 485e17628ca4..50c3aab15e6a 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1 +1,2 @@
DIST sybil-5.0.2.gh.tar.gz 56319 BLAKE2B 56c64c0110a7d0e808eaf786a22e8ce30572a8546be85987b4c26d86e1d8ea8c3f35557463a032a32b23861e7403a4196b03ab0b4d2641d6854f5d4cfd6d4b18 SHA512 43b8a7e6067d99a82e1ef07fce0a2034402db086f5a2043c0c4136eca8bf27a2e53d26f03d0e717b05076a5e65cfc259e685c883a7526840135454a6c68c3100
+DIST sybil-5.0.3.gh.tar.gz 56660 BLAKE2B 99af245f765630523ab2c6cb21452a0c3a970109102900530f5528ac0902d0472ceb09778bd266e9071816de1da397480e53220a974c5cc38f40367d552cef5e SHA512 0e2a96457b506558b4e9c58890a370c63dbde2c36780dd031cfe8de828f15a2f790c55df81d86800599302958006e704e627b7e8a5d3dd786398ce5f8ea46d35
diff --git a/dev-python/sybil/sybil-5.0.3.ebuild b/dev-python/sybil/sybil-5.0.3.ebuild
new file mode 100644
index 000000000000..e18ec7aee855
--- /dev/null
+++ b/dev-python/sybil/sybil-5.0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest