summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-31 16:05:19 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-31 16:05:19 +0200
commitdab13bdbda7c938bd71682d68cd9a99984285cf1 (patch)
treeb09bcbba6413670b00b1d62eb102c8cc52c9ac6b /dev-python/sybil
parentdev-python/slixmpp: Remove old (diff)
downloadgentoo-dab13bdbda7c938bd71682d68cd9a99984285cf1.tar.gz
gentoo-dab13bdbda7c938bd71682d68cd9a99984285cf1.tar.bz2
gentoo-dab13bdbda7c938bd71682d68cd9a99984285cf1.zip
dev-python/sybil: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/files/sybil-3.0.0-test-order.patch45
-rw-r--r--dev-python/sybil/sybil-3.0.0.ebuild21
3 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 7eb33000d04d..df143e6c4dbb 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,2 +1 @@
-DIST sybil-3.0.0.tar.gz 38011 BLAKE2B 7a42d5b0f3f13ac111d9edc9f74cb4d968f49680bb33d267ee762e830b134fa8c2e1697834d6a6a7aa09c9cd1dc52552379ca43e6667ee844f54f34b8bd3ffc7 SHA512 b6f5b5ebdeeab2ecbe17b6f83f0bc7e83e68f8e784b6a0eea292020db42294f8a1d0288d208f8a5803d5866038c3226f0b7d0d177c91469c4651364078d1bb4d
DIST sybil-3.0.1.tar.gz 38265 BLAKE2B 3a9dd8d85a5a6228944f104d255826b4dfee80f5a349da3a0fa69edcfa0953145378f002c1bf834e21c0d382fc96a993b927bdc92bb3e9a84d34998ad6ade62f SHA512 312c57f0de646b1e7a3b992806362c1020b2d567c805d248e94ab22a336a8fc77704234e123e1ec74987bfea620b2f8c4d3714d32aee03587c615d3d90fe5558
diff --git a/dev-python/sybil/files/sybil-3.0.0-test-order.patch b/dev-python/sybil/files/sybil-3.0.0-test-order.patch
deleted file mode 100644
index 1badf5b06a19..000000000000
--- a/dev-python/sybil/files/sybil-3.0.0-test-order.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 4d1e1c891bd619a0dec0a265a930bf49050833d1 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Wed, 27 Oct 2021 13:07:01 +0200
-Subject: [PATCH] Restore sorting of test paths to make tests reliable again
-
-11496eb5761761b687ad4889b4173d3124caa844 has replaced the all_documents
-method with a direct call to glob. This has implicitly resulted
-in removal of path sorting that in turn means that the test output
-depends on filesystem order now and is no longer reliable.
-In particular, the tests can now fail randomly depending
-on the underlying filesystem, unpack/checkout order, etc. Restore
-explicit sorting to make test order predictable again.
-
-Fixes #34
----
- sybil/integration/unittest.py | 2 +-
- tests/test_sybil.py | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/sybil/integration/unittest.py b/sybil/integration/unittest.py
-index 7129ddf..ce34caf 100644
---- a/sybil/integration/unittest.py
-+++ b/sybil/integration/unittest.py
-@@ -38,7 +38,7 @@ def unittest_integration(sybil: 'Sybil'):
-
- def load_tests(loader=None, tests=None, pattern=None):
- suite = TestSuite()
-- for path in sybil.path.glob('**/*'):
-+ for path in sorted(sybil.path.glob('**/*')):
- if path.is_file() and sybil.should_parse(path):
- document = sybil.parse(path)
-
-diff --git a/tests/test_sybil.py b/tests/test_sybil.py
-index 74a04ea..72a5aea 100644
---- a/tests/test_sybil.py
-+++ b/tests/test_sybil.py
-@@ -243,7 +243,7 @@ def parse(document):
-
- def test_namespace(capsys):
- sybil = Sybil([parse], path='./samples')
-- documents = [sybil.parse(p) for p in sybil.path.glob('sample*.txt')]
-+ documents = [sybil.parse(p) for p in sorted(sybil.path.glob('sample*.txt'))]
- actual = []
- for document in documents:
- for example in document:
diff --git a/dev-python/sybil/sybil-3.0.0.ebuild b/dev-python/sybil/sybil-3.0.0.ebuild
deleted file mode 100644
index 0b0c9f2b1cfe..000000000000
--- a/dev-python/sybil/sybil-3.0.0.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Automated testing for the examples in your documentation"
-HOMEPAGE="https://github.com/simplistix/sybil"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-test-order.patch
-)