summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-08 14:36:21 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-08 15:26:02 +0100
commit959e273e233a445fb187884a778de45c3e5c5cd7 (patch)
treef0de4870c04a19622eba55de8ceffa473f4eb381 /dev-python/sybil
parentdev-python/sybil: Enable tests, set DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-959e273e233a445fb187884a778de45c3e5c5cd7.tar.gz
gentoo-959e273e233a445fb187884a778de45c3e5c5cd7.tar.bz2
gentoo-959e273e233a445fb187884a778de45c3e5c5cd7.zip
dev-python/sybil: Bump to 1.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-1.2.2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 4fd32cf00217..bcd01d0b0535 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1 +1,2 @@
DIST sybil-1.2.0.tar.gz 28720 BLAKE2B fc2fda9763a33cf89f47b5edf3aacf1d3c9ba712cc6e292dce0549393f2177afb6ff058e6c4ac96b0ffcc44149dab4c8da5da50ef6850555e374ca25906b1e14 SHA512 9355bfe2873eb9cec866a1c267deb876f3e6b1e452e0b7c951e5ffb642e79cb6602bc81384ff4e5bfff1adc0be2c95bcfa291d34b7690feae9b280a92b6b5c85
+DIST sybil-1.2.2.tar.gz 29182 BLAKE2B d0d9a0a2e5117efd36e7561f74d31283fa25ea0210e0796fe1a1cc4247712bff0e3ac329781987b5ba805ccd2cddf01eec2672d5e2677422d1ed378068482da5 SHA512 c1785c00ce1dfdaf85d13db976f28062c09c47974107bc2af54c3bd9bf4ad5124c9b52321f3350fb1cc50aefdf72f2a9b6b22fc766b139516ff7979864604735
diff --git a/dev-python/sybil/sybil-1.2.2.ebuild b/dev-python/sybil/sybil-1.2.2.ebuild
new file mode 100644
index 000000000000..3918a42c35cd
--- /dev/null
+++ b/dev-python/sybil/sybil-1.2.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="https://github.com/cjw296/sybil"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# nose is used to test nosetests integration
+BDEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest