summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-23 06:41:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-23 07:38:08 +0200
commit7ee224b7ce52f64dc03a2416348b231e3aeeab4e (patch)
treeffd1545b05257d01878e5fce5a74b2d1e6d647bb /dev-python/sybil
parentdev-python/types-setuptools: Bump to 69.5.0.20240423 (diff)
downloadgentoo-7ee224b7ce52f64dc03a2416348b231e3aeeab4e.tar.gz
gentoo-7ee224b7ce52f64dc03a2416348b231e3aeeab4e.tar.bz2
gentoo-7ee224b7ce52f64dc03a2416348b231e3aeeab4e.zip
dev-python/sybil: Bump to 6.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-6.1.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 6334c9906f97..c6558a2d551c 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1 +1,2 @@
DIST sybil-6.0.3.gh.tar.gz 67772 BLAKE2B e90b7a01373d931ca056bfce1336bab8a579a25e17000675d77cd849081275970b455c7bc77f30e0fd104073115915fc4f4477b010eafd35e57aec322fb42fc4 SHA512 1fb42b944b237556012ace6fcc5eb3d0f067f0ca043ceafa0e201a8076870fc7e06ae62813eec90d486de6e4b71ebf29176dfff6573de423480c688ff005004d
+DIST sybil-6.1.0.gh.tar.gz 70823 BLAKE2B dfdd931f1f2bb7944a97ceb92425e55accc8d7587c829b65be9b6b65007f8a32b076938e1114bbee76d0a9592ba29335cf88e982aa00d1a3ad17c8523f162548 SHA512 2048073c8ef8a9c0f71dabe39ada1404eef3d83509fe3f3e0a7e6b5d1f65a24242c8faf14aaac9ea12b21ab5908dee9bae9d03d9907f09a830d73a3b6e52f8d3
diff --git a/dev-python/sybil/sybil-6.1.0.ebuild b/dev-python/sybil/sybil-6.1.0.ebuild
new file mode 100644
index 000000000000..adf69fd38724
--- /dev/null
+++ b/dev-python/sybil/sybil-6.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}