summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-25 20:05:31 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-11 09:17:22 +0200
commit303cf67dd740f357ab4f091351d57c0562c94e14 (patch)
tree8eeedaed76ed31b8209583ed49f6ed6db4a1da2f /dev-python/spyder-notebook
parentdev-ruby/bundler-audit: add 0.8.0 (diff)
downloadgentoo-303cf67dd740f357ab4f091351d57c0562c94e14.tar.gz
gentoo-303cf67dd740f357ab4f091351d57c0562c94e14.tar.bz2
gentoo-303cf67dd740f357ab4f091351d57c0562c94e14.zip
dev-python/spyder-notebook: version bump 0.3.2
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/spyder-notebook')
-rw-r--r--dev-python/spyder-notebook/Manifest1
-rw-r--r--dev-python/spyder-notebook/spyder-notebook-0.3.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/spyder-notebook/Manifest b/dev-python/spyder-notebook/Manifest
index 40c3ee482455..40f649fffe9c 100644
--- a/dev-python/spyder-notebook/Manifest
+++ b/dev-python/spyder-notebook/Manifest
@@ -1 +1,2 @@
DIST spyder-notebook-0.3.1.tar.gz 3862401 BLAKE2B cfafc631fc0fe44fadecc1f2509435c0a7b6ce5320c19bbe75be92e4c50275a06e79aa77e8b0cf832fbb1fdb229236c3741208f3081e879528751373d8875126 SHA512 253583b0a080f6359b58583f8c459ae858bafe4b15d24e86c7f144801431bd03254ced3984ac98e1e3349f48ebe5081252d298e59dd88609b7bb22f9e0b6765d
+DIST spyder-notebook-0.3.2.tar.gz 3868854 BLAKE2B ca13e905dcc02d6767002481fb68ab8bc119d4d2511a1b881f033b9387d4237a1b2232ba75368f48b4d096998da40a14d862f125c0b01c6b2498165acebf4835 SHA512 dd3b505c8a678a9f49b1fce1d22a8a1a6cf334b65d1ab94852a7ba2120f53e2e38eb2fa0d58343588d7304511d7171d8e0040e10cda905db11ab65cae7f6ce5c
diff --git a/dev-python/spyder-notebook/spyder-notebook-0.3.2.ebuild b/dev-python/spyder-notebook/spyder-notebook-0.3.2.ebuild
new file mode 100644
index 000000000000..5644ae3cc7a6
--- /dev/null
+++ b/dev-python/spyder-notebook/spyder-notebook-0.3.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Jupyter notebook integration with Spyder"
+HOMEPAGE="https://github.com/spyder-ide/spyder-notebook"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/qdarkstyle[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/spyder-4.1.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+DOCS=( "README.md" "RELEASE.md" "CHANGELOG.md" "doc/example.gif" )
+
+# Tests do not work inside virtx/emerge for some reason, core dumped
+RESTRICT="test"
+distutils_enable_tests pytest
+
+python_test() {
+ virtx pytest -vv
+}